Watched Files in "storage"

(Robert W Cater Jr) #1

Core Machine (Operating system/System info/Roon build number)
iMac OS 10.14

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
Chord Qutest DAC USB connection

Description Of Issue
The default watched file in preferences:storage is the internal SSD installed in my Nucleus+ and I cannot find a way to specify my iTunes music file on my desktop instead.

Any step-by-step directions would be appreciated.

(Dylan Caudill) #4

Hi @Robert_W_Cater_Jr,

Just to verify, is the iTunes media stored on a Mac? If so, we have instructions that walk you through sharing media over the network and adding it to Roon here:

https://kb.roonlabs.com/FAQ:_How_do_I_create_a_shared_folder_on_Mac_and_add_it_as_a_watched_folder_in_Roon%3F

(Scott G) #5

Just noticed he had a Mac. My instructions were for a PC. Doh!

(Robert W Cater Jr) #8

Thank you but no matter how I specify share folder path I get one of two messages. Either “Host could not be found” or “unexpected error”. I’m not an expert but my friends look to me to help them with their computer related problems and this should not be this difficult on anything costing what a Nucleus+ costs!!

(JohnV) #9

I troubleshoot only my own problems and, mercifully, do not do it for a living. So, consider the source.

That said, I would confirm that the folder has been successfully shared. Second, retrace your steps and pay attention to every detail. Has SMB sharing been enabled? Have you used the correct User name and syntax for defining the folder path? Are you using the correct Mac user Name? Any one of these details, and others, can cause failure.

I apologize if this sounds patronizing in any way. The path to success is to slow down and recreate exactly the steps in the KB, after you have rebooted your machine.

FWIW, I did things differently. I moved my itunes Media folder into my internal SSD (or the equivalent; mine is a NUC ROCK with an an external HDD). Then I pointed iTunes to the new location. Whatever…

Hope you find success.

(Robert W Cater Jr) #10

John,

Thank you for your response. However, I have already checked everything you suggested. On a Mac you can trace the path of a file through the “Get Info” file function. If you edit out the right pointing triangles and replace them with slashes, you wind up with a track to the destination file. In the System Preferences “Sharing” panel, it identifies the host name. I have used the host name, the computer name with both followed by the hard drive name and the path to the location of the music file used by iTunes. I have even checked the case of all the characters in the path and to make sure all the slashes are where they should be.

When nothing worked, I copied my desktop based music files to the internal SSD I installed in the Nucleus+. While the music was available and played without problem I began to notice missing album artwork that required either re-scanning or internet “Identification”. I have, thus far, found one file that Roon misnamed from I know not where.

It is disappointing to see the setup of what is an elegant interface prove to be frustrating beyond reason.

While “copy and paste” is relatively easy when music is added, it shouldn’t be necessary at this price point.

Best regards,

Robert

(Daniel Beyer) #11

You might have already tried it, but, try the IP address instead of the Mac hostname and see if it makes a difference.

(Robert W Cater Jr) #12

Thank you but been there, done that (smiles)

(Geoff Coupe) #13

Um - I don’t think you should be including the hard drive name in the network address path?

(Dylan Caudill) #14

Hi @Robert_W_Cater_Jr,

Can you share the path that you’ve entered into Roon here so we can take a look?

(Robert W Cater Jr) #15

The common path is: Users/{my user name}/Music/iTunes Bobby
Variations included the common path preceded by:
Macintosh HD/
MacNet.local/
Either smb:// or \ or {computer name}/ preceding the above
And various combinations of all the above.

Also, how do I correct Roon’s breaking one album into two with different tracks in each?

Thanks and I hope you can help.

PS - \ is actually double \

#16

If you followed the Kb instructions your path should be

smb://MacNet.local/Music

@support - your KB screenshots for these instructions are from a quite outdated version of MacOS.

(Robert W Cater Jr) #17

That path gave me a “host not found” error message.

Thanks anyway

(Geoff Coupe) #18

just type three backslashes to get two - it’s a feature, not a bug, of the Discourse software used by the Roon forum… :grinning:

(Geoff Coupe) #19

https://kb.roonlabs.com/Merge_Albums

(Robert W Cater Jr) #20

Never would have thought about triple \ !! That’s funny…and thank you for the merging link.
Robert

(Dylan Caudill) #21

Hi @Robert_W_Cater_Jr,

Can you share a screenshot of the folder you’re trying to use in Mac showing the share?

Can you also verify that you’re entering a username and password here?

(Robert W Cater Jr) #22

Dylan,

For clarity, are you referring to “network share”? If so, the KB says to use “guest” for the user name and password. Is that correct?

I will watch for your reply but will not be able to do anything further until Sunday.

Thank you,

Robert

(Daniel Beyer) #23

It all depends on how you have the security set on the Mac’s network share. I have to use a real username and password, as well as Workgroup, before Roon sees my Window’s Shares.

I would try the username and password you use to log into the Mac.

(Dylan Caudill) #24

Hi @Robert_W_Cater_Jr,

“Guest” for the network share is when accessing the internal storage of the Nucleus over the network. When adding a watched folder in Roon, you need to use the Username and Password for the Mac account – This would be the login you’d use to log in to the Mac itself, as Daniel mentioned above.