Watched Folders No Longer Working

Roon Core Machine

Synology DS918+ DSM 7.0

Networking Gear & Setup Details

Edgerouter X, Ethernet, 100/20Mbit Internet

Connected Audio Devices

2x USB DAC’s, Chromecast

Number of Tracks in Library

45132 Tracks

Description of Issue

Since the lastest roon Update this week, my watched folder no longer auto imports albums that are dropped in there. It worked fine before this.

Checked my NAS permissions, nothing has changed.

I can manually scan the folder like this and it always imports fine.

But it just will not pickup tracks in real time anymore. I have tried rebooting client’s, server etc. to no avail.

Log files can be PM’d if needed to support.

This has always been the case for me. I have a DS1621+ with Roon Core running on a NUC with Ubuntu server. My NAS share with music is mounted on my Ubuntu server with Roon pointing to that mount.

See, watched folder worked flawlessly for me until the lastest few updates over the last couple of weeks.

If they would just allow a setting to schedule a force rescan or allow a force rescan from command line so I could setup a cron job.

Er - they do have a setting to force a scheduled rescan on network connections; for the very reasons that some NASes are notorious for not reporting realtime changes.

In the screenshot above, click on the Edit menu option - then you will see the option to set up a rescan interval…

@Snook - have you tried using this as a workaround? And has your Synology recently had an OS update, which might be the reason for the change in behaviour?

Er, no they don’t:

That’s locally attached storage - I said network attached storage…

Except it’s not. That is the mount point to my NAS (via the OS). If I use Roon to create the mount point I get drops during playback. This is not surprising as most software (eg. Kodi) works better when the mount point is created on the OS rather than in the software.

It’s locally attached as far as Roon is aware, because you’ve mounted it… And if you get dropouts when using it as network attached storage, then something else is going on - and it’s probably not in Roon…

If I mount the share at the Roon level I get dropouts. If I mount it at the OS level (which is how it should be done anyway especially on Linux) then I do NOT get dropouts so clearly the issue is Roon.

I updated to DSM 7 a month ago, but auto watched folders worked perfectly for a few weeks. It only broke since the latest ROON updates over the last week, which came 3 times since they had so many bugs. This is another one I am sure… Needs attention from the devs.

I agree with glc650.

You should always mount directly at the OS level, fundamentally this is much smoother, faster and more stable.

The equivalent in windows would be making a share such as C:\Music and then mapping it as a network drive and adding it as an SMB share for a local application. You can see the stupidity in that easier.

Which is why the force rescan scheduler should be always available (not just for shares mapped at app level).

1 Like

I have the same problem since 933 update.
And also I am annoyed by the fact that local mounted folders are not automatically watched.
The mount process in Roon is not the best one.
At least, the possibility to insert additional parameters could be deployed.
I think this a change that must be made as soon as possible.

2 Likes

I just fixed it by doing this on DSM at every boot FYI

But still, this is dumb :frowning: at least it works.

This should def be on Roons Known ‘issues’ fort roononnas project with the fix for NAS and iNotify…