Watching folder does not work


I am not sure if this is the correct category to post my question.
Currently I am trying Roon core on a linux machine with a mounted volume from my QNAP as watched folder.
From what I understand the core will scan that folder realtime for new files, at least that is written in the dialog.
The mount is nfs share from my QNAP (TS-879U-RP), in this way I bypass smb so that should not be the cause of the problem.
I placed some new music in the folder but it is not being detected until I manually choose “Force rescan”
Have I configured some wrong (probably :slight_smile: ), or is this a known issue with the core?


Just a small addition, just installed 207, my scanning issue is not yet fixed

Updated to 208, still does not work.
in both 207 and 208 is written that directory scanning is fixed.
Obviously that raises the question if that fix is also for my “watch folder” issue :slight_smile:

I may can confirm your problem. But only related to Qnap. My SonicTransporter i5 is ok.

My issue was (yesterday) that no albums etc showed up in totals, even though that they where present in library.

If needed, I can connect back to my Qnap and confirm problems still exist.

Please take backup if not have already :grinning:

Hopefully support will contact you and if other Qnap users discover this issue, please post.

Also you may notice there is a new qpck out, though there is no changes, except better logging. (According to crieke)

Edit 2:
Your Roon is on the Qnap ?

Typically the reason this sort of thing happens is that the OS is failing to inform us of changes to the folder we’re attempting to watch. I’m aware of some bad situations with SMB around this, I’m not surprised to find that they’re also present on NFS. I’m also not sure what we can do about them, if the OS doesn’t want tell us about changes there’s very little we can do to force it to.

The one obvious thing you might try is confirming that you have enough inotify watches for us to watch everything. Do this on the terminal on the system running your Roon core:
cat /proc/sys/fs/inotify/max_user_watches

Ideally that number is ~1 million, but some systems ship with it set to ~8192 or similar by default.

Roon is not on my qnap as package, it is a separte machine with nfs mount to the qnap
The cpu load on my qnap is to high to run Roon core on it.
I just changed the parameter max_user watches, that didn’t fix the issue.
Is there an option to just make a schedule that rescans my storage folders.
For what it is worth, when Roon core restarts it does pick up the changes.
Hmmm, I could make a cron job that restarts the roonserver.service every minute :smile:

Just added a fodler based on smb to the rooncore, that one is also not working.

Maybe off topic, but what Qnap are you running. My friends HS-251 with 2GB still manage well 40000 tracks. Spinning disks.

I am running a TS-879U-RP, rackmount with 5 hdd’s in raid 5 with 2 SSD as read/write caching disks.
Core i5 CPU and 16GB of RAM
But also running several virtual machines on it with QVM that on a regular basis max out the CPU for 5-10 minutes.
That is my biggest worry, but with a high cpu load I still maintain good transfer speeds of data to my devices.

Ben, I will have a look at
There is something like a File Alternation Monitor, I am running ubuntu lts16.04
Will check this the next days to see if that might be the solution for it, will keep you informed

That’s a heavy Qnap. May I suggest you test Roon on it. I predict you may find a lift in sq, but there I can be totally wrong.

Funny you run virtual mashies. I was hoping to do same, but stayed hyper-V as I realized Qnap really need good hardware to do. (Like yours probably)

May I ask a very stupid question.:
Ever considered running Roon on your VM’s ?

Rooncore is a virtual machine, but runnng on vmware’s ESXi
It has been a qpkg on the qnap I lost connection to the core on a regular basis so I went to a linux machine on ESXi
That runs perfect.
What is your thought about sq improvement, I do not see why it would be better?
But I am also new to the entire concept of Roon, (Old school user, only played albums and cd’s)

I can’t argue that the Qnap will serve you better SQ. It may well be the VMvare that raise the SQ. There is out a new Qnap pck with better error tracking.

You may test it. If you still have that problem, you can drop crieke a message, and he will check your logfiles. Maybe just change the Ethernet cable can help.

It is interesting to hear if you notice any SQ differences.

Also do you run HQPlayer as VM ?

I tried to get inotify working last night without success so no automatic scanning for me.
I removed to more heavy qvm’s from the QNAP and added the roon.qpkg
Let’s see if it keeps working correctly.
At this moment is difficult to decide what sounds better, I am running roon on my mac with a simple tascam DAC.
I am not using HQplayer

Just a small update.
Last week I removed some heavy machines from qvm and I am basicly only running the core on it.
Playback to multiple devices works good, I am upsampling where possible
As the QNAP is also iSCSI target for my virtual machines I was expecting some issues with either of them, notably the core but it just works great, no drops at this moment.
The issue of the watching folder is obviosly fixed :slight_smile: