WD MyBooklive SMB problems


Excuse my ignorance if this is simple to most.
I have a macbook pro (new mac user) and I’m trying to map Roon to my Mybooklive nas.
It finds the nas and required folder but then produces the error that only smb drives are monitored and not afp?

Any help would be gratefully appreciated.

Many Thanks


You can force the mapping to use the SMB protocol (instead of AFP) with the smb:// prefix: smb://name_of_your_NAS/name_of_your_folder

There’s a FAQ item with more info here:


Thanks for the reply Rene.

Tried this but it just hangs and says connecting to server.

I can see the music files ok in finder.

From what I gather, the MyBook Live is hardly a full-featured NAS, but anyway: the most important thing is avoiding AFP connections (direct Finder browsing will use AFP by default).

Maybe one of these posts will help you out:

https://community.wd.com/t/an-osx-answer-for-slow-mybook-live-connections-smb-not-afp/57587 (first post)

https://community.wd.com/t/mybook-live-very-slow-on-mac/59619/13 (last post)

Ignore the slowness remarks – I was searching for ‘mac smb’, not ‘slow’. :wink:

Thanks Rene, yes maybe time to get a proper Nas.

I’ll take a look at the posts.

Thanks for your help

still no luck, anyone else experienced this?