Weird distortion

Core Machine (Operating system/System info/Roon build number)

OS Name Microsoft Windows 10 Home
System Model Inspiron 3880
System Type x64-based PC
System SKU 09B6
Processor Intel® Core™ i5-10400 CPU @ 2.90GHz, 2904 Mhz, 6 Core(s), 12 Logical Processor(s)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD 3045 D, USB
Description Of Issue

I’m getting a weird distortion, it only lasts a second or 2. It happens at 2 min after the hour, like clockwork. Tidal flac, mqa, or from my library doesn’t seem to mater. Tried restarting everything a couple times, doesn’t make a difference. I’m not quite sure where to start troubleshooting,

General-purpose PCs have (at least) two potential issues as USB audio sources: 1) periodic PC tasks may run briefly at high priority and preempt the Roon task sending digital audio via USB; 2) those tasks may create extra switching activity that sends electrical noise down the USB wire that interferes with the DAC’s operation.

1 Like

Sounds like the usb input on the NAD is not up to much and picks up interference from pc. You best bet maybe to move to a dedicated usb audio device and not pc. You could try a Raspberry pi install Ropieee add an Spdif card or use it’s usb and see if its helps or you can go up the ladder to one of the more expensive devices from Allo, SoTM or Sonore. Or look to use a streamer with more digital outputs than usb. Usb is not always implemented well and is prone to noise if the device connected is electrically noisy and the DAC it’s self is not filtering as good as it should. In some cases changing cable might help.

Ok, I have a Chromecast audio, I’ll try that and see if it goes away. I was thinking a physical connection is better, but that may not be the case.

Hello @Tom_McClelland, could you also please test this with your core connected to Ethernet?

I am unable to try direct Ethernet, I played through my Chromecast, I don’t get any distortion but I get quite a few dropouts, which are way more frequent and annoying than the distortion.(and my amp won’t do mqa through the optical in)

When I get time I’ll try a new cable,

Is there any way to dedicate a specific usb port to the audio driver and nothing else?

Ensure you have elusive mode on if it’s using WASAPI to connect to the amp. This will give Roon exclusive control of sound to the amp. You can’t set one port to run the driver as far as I know.

1 Like

I’m using the NAD ASIO driver, I was on exclusive mode, tried turning it off, no luck. Tried turning on maximum buffer size, no change. Buffer size power of 2, also no change.

And as I’m writing this, I’m realizing I’ve been listening for a couple hours now with no distortion/breakup, only change I can think of is I’m just controlling roon on my desktop not using roon remote from my android…

Any chance that’s the issue? Ideas too resolve?

I did a little more digging, thought maybe my usb cable was to long (12ft), I got a 10’ powered usb repeater cable and 1.5’ usb cable, if anything I think it may be worse now. I may just have to try an outboard dac, :disappointed:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.