What am I doing wrong - track meta data question

I have just added an album to a roon-watched directory. The album then appears in roon, but the track titles are not setting as expected. As background, I have a couple thousand albums, and have not encountered this issue before.

The album is Das Rheingold, disc 1. The problem is happening with all tracks, but if we look only the first track (Vorspiel), it will demonstrate the challenge.

  • The track title in the meta-data is: “Das Rheingold: Vorspiel”
  • The import setting “Prefer file” for track title
  • I have added the following custom tags
    WORK: Das Rheingold
    PART: Vorspiel

Nevertheless, the displayed title is being chosen (I assume) from the roon db.

  • After import, I attempted to coerce the title by editing the track (using roon’s UI) to the track title from the file, but this appears to have had no effect.

Please see the attached screenshots

Any clues as to what I’ve done wrong would be very much appreciated.

Thank you

I have had 1 or 2 cases like this as well (cannot remember which ones though)
I got rid of the problem by using ‘edit’ and enter exact same info as in my file’s metadata.
Roon was picking up that information.
Hopefully this willl work for you as well

Thanks for the thought

In this case, it would be about 190 tracks, and I’m way too lazy for that.

I hope you will get a cogent explanation of what is at work here from Roon. I could speculate but that’s all it would be.

Frankly, Roon doesn’t volunteer such information lightly.



I’m confident that another forum member or roon support will help me figure it out. The one other time I had a mystery, it got solved pretty quickly with some insight from the support folks.

@Akimo There is a difference between track titles and composition part names. If you “prefer file” for track titles, this will not change the presentation of identified compositions which are using composition name and part names from the Roon metadata service.

To change part names for a composition in an identified album, you need to have WORK/PART file tags — as you have done — but also “prefer file” for multi-part composition structure (there is a setting for this in the album metadata preferences).

If this does not work, please would you let us know?

St prefer file at Album level, not track level

It should work

joel & Mike_O_Neill,

Thanks very much. That did the track.

I had never noticed that preference, but will keep an eye out for it in the future.

1 Like

3 posts were split to a new topic: Compositions not identified by composer

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.