What am I doing wrong?

Hi folks, hoping someone here can help…

I have recently got hold of a rPi 4 and successfully loaded Ropieee onto it - that bit was easy :slight_smile: However when i try to set it up as an endpoint there is nothing visible within my Roon > Audio preferences.

I have tried with multiple sd cards, reinstalled twice, restarted my core several times etc.

The dac is an Amanero 384 based dac, so in theory it’s supported.

I did try RopieeeXL, and the endpoint shows up under Airplay, but this is less than ideal as it downscaling higher bitrate files to 16bit. Id far rather have it set up as a Roon endpoint so I take advantage of the native dac functionality.

Hopefully someone can help!

Cheers, Phil

I did send feedback… 58dd2591fd2bf147

Helpers will, at the very least,probably want a screen shot of your Settings==>Audio screen.

Sure. I’ve since disabled XL so no airplay option in here…


Hi @Philip_Dall,

Let’s leave XL out of this, that just complicates matters.

What I see in the log that the unit has a problem with downloading RoonBridge (which it does on install). It says that the archive is corrupt.

So that’s the reason that the unit does not become visible in Roon because RoonBridge is not running. The DAC is recognized, so for the rest everything is ok.

I’ll have a look what’s going on with the archive. Maybe Roon has changed something here…

Thanks

@Philip_Dall,

Can you reboot and wait? Could be that the Roon guys were just updating the archive and that’s the reason why it’s damaged.

Thanks for checking this out Harry, you’ve really helped me.

My network at home is quite locked down, and turns out the ropieee was trying to get out with a different dns server than what my network requires - quick firewall exception and all fixed!

Thanks so much for the help… Now let’s have a listen :slight_smile:

1 Like

OK, so now that the endpoint is working well i’ve tried to get the display attached and working.

Initially I plugged it in and hoped it would be recognised, and while i could see the command line bootup there wasn’t much else. So i did it properly, reflashed and reset everything up, the display is working but i cannot get the ‘display’ tab under ropieee settings to appear. On bootup it says ‘touch recognised’ but still no ‘display’ tab.

I’ve tried two different cards and reflashed 4 times but had the same result every time. I have named the endpoint within roon as the same name, and have also enabled the extension within roon.

What am i missing?

I did send feedback in case you wanted to check the config - Unique identifier 386efb4ba2b81185

Many thanks in advance! Phil

I’m not sure what you mean with ‘on bootup’…
But there’s no touchscreen detected.

To be clear:

  1. touchscreen support is enabled during installation. Plugin it in afterwards won’t work.
  2. only an official Raspberry Pi touchscreen is supported.

Apologies if I confused you, what I meant was that I could see all of the console boot messages but no ‘display’ tab. I am using the official display and had tried reinstalling from scratch several times.

I have since managed to get it to work though. I realised the image i was using was slightly older (0902 vs 0910) - I tried the new one and it worked! I was under the impression it updated to the new image on boot so was surprised this made a difference.

Now I have it all running as expected I do have one more question… The colours on the display I have are very washed out and faded - perhaps I have a dud (or they just aren’t great quality) but was wondering if i’d be able to tweak this through the command line. After some googling I tried logging in via ssh and calling the ‘xgamma’ command but only get ‘command not found’. Is this disabled or is there any way i could change screen gamma/contrast on ropieee?

PS. Just donated. Thanks for such great software and excellent support. Hugely appreciated!

Yes RoPieee updates during installation. Your unit did as well, but the screen was not properly recognized hence the software was not installed. Could be a loose connection (I’ve had that myself, the flat cable is rather flimpsy).

But anyways, you’ve got it running. xgamma is not present on the system as RoPieee does not use X but OpenGL directly.

You can adjust the contrast in the settings of the touchscreen, press the right lower corner.

Ok, I already found that, although it seems to just control the backlight brightness and not the gamma per se. I guess that it is not possible, but thought it wouldn’t hurt to ask.

Thanks again, Phil