What are you doing in HQP with MQA files?

Now that Roon 1.5 has implemented first unfolding of MQA, what are we all doing with MQA files in HQP ?

Personally, if I find an MQA file that says it has an ORFS (MQA talk for unfolded sampling frequency) of 88.2 and up then I make it my primary (unless I have a local hi res version) and Core Unfold it to HQP and my non-MQA DAC (Holo Audio Spring). If an MQA file has an ORFS of 44.1 or 48k (as an alarming number do) then I ignore it and make another file the primary version.

In HQP I am currently upsampling everything to DSD 512 using xtr-2s (linear phase) filter and the DSD7 256+fs modulator.

I have tried the mqa filters in HQP, but prefer the linear phase xtr-2s for soundstage and the minimum phase shrt-mp for transients. I understand the mqa filters are adapted to higher sampling rate material and have good bandwidth rejection.

1 Like

I’m pretty sure Jussi’s reply will be avoiding them like the plague.

1 Like

Embedded has a feature that allows setting different rates for 1x (44/48k) and Nx (high res) content. (I understand this will eventually appear in Desktop, no timeline.) With well-mastered, local high-res files I have been enjoying minringFIR-lp so I will try that with MQA when I have a chance.

1 Like

I want HQP to upsample the unfolded MQA file. How do you set it up to do that? Would HQP be the renderer? I have an MQA dac if that matters

With an HQPlayer zone this seems to be default behaviour. I’ve done nothing but update and press play, HQPlayer shows receiving a 96k rate.

@lorin Do you listen to a lot of Jazz with that filter? Thanks

I do indeed! Much of my high res listening is jazz. Spacious, airy, wide soundstage with unmuffled, accurate treble extension is how I would describe what I hear. Here’s a screenshot of the zone setting with the new iOS app. This was the default.

Excellent! I will give that filter a listen. I listen to Jazz primarily and have been using the XTR - 2’s. Now that flac radio playback is supported, I need to find a good jazz station

Yup and the Roon signal shows MQA Core Decoding to 88k/96k before ‘signal leaves Roon’ for HQP.

I had asked Jussi about slow roll-off filters suited specifically to upsampling high res and that was one he suggested. It’s non-apodizing and so apparently is more variable from recording to recording.

I just made the filter switch. Thank you!

1 Like

poly-sinc-mqa(-lp) is a slow roll-off filter that fits well also for unfolded MQA, if you like “MQA’ish” filter. It is apodizing one, so you get the “deblur” functionality too. minringFIR is non-apodizing alternative.

The intermediate poly-sinc-short and the steeper alternatives work fine too, being vastly different from the MQA-style filters. So you can listen and choose what you prefer…

1 Like

Roon will default to HQP upsampling an unfolded MQA file, but it is best not to unfold files where the MQA content is only 44.1/48 because that is just upsampled to 88.2/96 and HQP can do that. HQP does not render MQA files (in an officially authorised way, it does an equivalent job as per Jussi’s post below), but if you set Device Settings for HQP to Renderer only then the information for your DAC to render might be passed through. Haven’t checked it out.

“Render” == upsample. Yes you can do that, just not with the MQA filter set… :wink:

2 Likes

Ok, please forgive my being slow here but are you saying Roon’s decoder should be set to off for 44.1/48 and just allow the file to play as normal with HQP filter being applied? I upsample everything to DSD generally

You could do that, but I would find it annoying to change the Decoder setting according to format. Instead I decide which version to make Primary. If all that is on offer from Tidal Masters is 44.1/48 ORFS, then I’ll make a local or Tidal Redbook version Primary. If I can get 88.1/96 ORFS or better, then I make the MQA version Primary. That way I can just leave the Decoder on.

It’s not a huge issue for me and I wouldn’t be bothered turning the Decoder off if all I can get is 44.1/48 ORFS. The Decoder is just upsampling that material, there is no recorded hi res content there. Might as well get HQP to upsample.

It also depends, of course, on the mix. A good mix preserving DR is preferable to a compressed loudness warrior, no matter what MQA status it has.

Edit: Brian has noted that when the Decoder outputs an 88.2/96 stream for an ORFS 44.1/48 MQA file then Roon is not upsampling. The decoded content has been created in the MQA encoding:

I’m not convinced that ORFS 44.1/48 MQA files have an audible advantage over non-MQA and will judge between versions according to mix. I doubt my ability to hear any audible difference except between different mixes in this case.

Seems to me that you would setup Roon to just do the unfold (decode, no renderer and have your output in Roon set as HQP. Then the unfolded file should get sent to HQP and HQP will treat it just as it would any other file. You won’t get the MQA “rendering” this way, though, just the unfold.

Ok. This is exactly what I want to do. I just want HQP’s filters so now I understand. Thank you

1 Like

Anyone else using a Singxer SU1?

It seems not to be able to manage 48k MQA files into my Holo Spring DAC. It seems to be playing but there is no sound.





Whereas Direct to Holo works fine.




Is this something specific to me?

Would downsampling 48 to 44 in Roon before sending to HQP introduce any sound quality degradation?


Or I should there some other workaround?


.sjb

Perhaps the Holo can handle both ~22.6MHz (DSD512) and ~24.5MHz (DSD512x48) sample rates?

But the SU-1 can only handle ~22.6MHz and NOT ~24.5MHz?

Can you select the ~22.6MHz (DSD512) sample rate in HQP SDM output mode, to force everything to that sample rate? To keep the SU-1 happy.

Rather than down-sampling in Roon side.