What does the Version field map in Flac

@support I see that the Album Editor lets you select if Version is read from file

But what does this field actually have to be called in the Flac file to be recognized. I have tried VERSION and it hasn’t worked for me.

I already sent you the answer, it’s version, as shown here:

Perhaps you need to force a rescan of the files within Roon?


Thank is that a special view because it looks different to mine when I look at an album

What does it show under credits?

Not sure how that is relevant but here is a screenshot

Edit Album still shows as blank and I have VERSION, ROONVERSION and ALBUMVERSION tags in the file now.

  1. Could it be that the value of VERSION has to pass some validation ?
  2. Does VERSION definently work with standard Roon 1.7 version ?

According to the KB and my own experience, yes.

I have experienced Roon DB as rather unwilling to change data that is already there (or not). To work around this I move files out of the Roon watched folder, clean the DB, move the files back in and do a rescan. Helps most of the time…

I am interested I didn’t realize Roon was importing version I have been doing it manually or by [Square Bracket] suffix in the album folder name So I tried it …

I have an album in HiRes and CD quality otherwise identical

I removed the album
Cleaned the DB
Set tag Version = Version Test and Hi Res Version(In JRiver)
Replaced file in watched folder

Voila it works , I had to change the tag in JRiver to write to file ?


Should I be able to see the Version tag in SongKong or is that what you are working on ? I c’t see it under Album or AlbumAdvanced.

Can I see Custom Tags in SongKong ?

No, it is something Im working on for next release.

No you cannot.

Okay that is good to know, is the file FLAC or WAV ?

FLAC , I only use FLAC occasional MP3

Just cant see why it is not working, you can see I have VERSION (comment[27]) set using the same metaflac tool

In my case the Version tag was default to write to library not write to file (in JRiver)

As I changed it to Write to File it it worked. My tag was called Album Version , I copied this across to [Version] and Roon whirred away and imported the lot. I randomly checked a sample they all seem to be there

Sorry @support I think I should have posted this in the Support category

Moved it for you.

Hi @Rugby its not a feature request, Roon already supports reading version from file, except I cannot get it working.

Sorry, must have mis-clicked, should be support now.

Already checked if “Extract album version from VERSION tag” in Settings > Library > Import Settings is set to “Yes”?

heh, that was it THANKYOU, why is it disabled by default ?

Its confusing that it is disabled by default and that Edit Album shows file Version as blank when it actually has a value.