What happened to my album artwork?

Roon Core Machine

iMac, macOS Catalina 10.15.7, 3.1 GHz Quad-Core Intel Core i7 , 8GB RAM

Networking Gear & Setup Details

iMac is connected via ethernet to last model of Airport Extreme Apple released and is working fine.

Mainly streaming TIDAL through ROON to Bluesound Node 2i and Bluesound Mini 2i + through ROON core iMac desktop

Connected Audio Devices

Bluesound Node 2i and Bluesound Mini 2i using iPhone 12 Pro & iPad Mini 5 for controllers.

Number of Tracks in Library

Mainly streaming from TIDAL through ROON

Description of Issue

Album artwork is not showing on ROON Core software via iMac. Also checked ROON app on iPhone 12 pro and album artwork doesn’t show on queue for playlists. However it does show for individual songs while playing.

Hey @Brett_Lancaster,

Thanks for taking a moment to share what you see on your screen when using Roon, or rather, what you don’t see… :see_no_evil:

We’re very sorry about the trouble. While it may be naive, many times a good old fashioned reboot sets things straight. If you haven’t yet, could you please:

  • quit Roon on your iMac
  • turn off the iMac and unplug it for a few minutes
  • plug it back in and turn it on
  • launch Roon

You mentioned mainly streaming from TIDAL. Do you also have a local library? Is album artwork missing just for certain albums, or all of them? Is there an analysis in progress?

yep. that worked. thanks! can’t believe I didn’t think of that myself.

1 Like

How wonderful to hear! Thanks for sharing :pray: We’re enjoying the victory with you :partying_face: - sometimes, an easy step does more than one could ever dream!

today my iPhone 12 pro has the same problem. it was fine last night. tried deleting and adding back the ROON app, reset my phone. any fixes for this?

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hey @Brett_Lancaster,

So sorry to hear that the issue seems to be contagious… :pensive: . Thanks for already trying a few steps to resolve this :pray:

Could you please try navigating to Settings → Setup in the Roon Remote app on your phone? Could you please click on Clear Cache next to Clear Image Cache?

Does it help?

A post was split to a new topic: Artwork not appearing on remote devices (Nucleus Core)

This topic was automatically closed after 21 hours. New replies are no longer allowed.