What OS do you prefer on RPi 4? (DSD popping problem)

Hi everyone,

I spent a lot of time tuning Roon on Synology and finally got ROCK running on NUC. The Roon Core is working smoothly. Now I’m trying hard to solve DSD popping noise on RPi. And that’s very confusing.

Here’s my setup:
An Intel NUC 10, i3 processor, running ROCK, wired connection.
RPi 3 and RPi 4 4GB RAM, with different OS installed on different SD card to test. Roon Bridge installed.
Sennheiser HDV 820 USB DAC connected to Pis using a USB cable.

On Pi 3 and Pi 4, wired or wireless, Moode Audio with bridge installed, I can hear popping while playing DSD128 via DoP. So Moode doesn’t work for me.

On Pi 3, DietPi+Allo GUI produces no popping, wired.

On Pi 4, DietPi+Allo GUI produces popping, wired, which is really weird. Maybe this version of DiePi wasn’t optimised for RPi 4? Already updated to latest DietPi.

All the popping sounds are not random, I can hear them when playing certain parts of the DSD files. But if I resample the files to PCM, the popping goes away.

I installed Ropieee XL on another SD card. The installation took a few hours, so I haven’t tested it yet.

I also tested PiCorePlayer, but Roon only permits me to play up to PCM 192kHz or DSD64. No popping. Will PiCore RT kernel support high rates?

Anyone has idea what is the best OS as bridge on Pi 4? I heard that Pi 4 has better USB bandwidth, but only to find that Pi 3 works better for me.

Try Moode Audio its very flexible and by far the best sounding software I’ve heard om my Pi 4

Have you tried playing DSD128 or above? Is there popping sound?

If you want to try RoPieee and only use Roon/RAAT then I suggest you stick with ‘regular RoPieee’. Saves you installation time :wink:

1 Like

I can’t say what’s the best but I have RoPieee XL running on an RPi4, handling DSD256 via DoP (and PCM768kHz) to an RME ADI-2 FS DAC, without issues.

Thank you spockfish! I tried various distros on two Pis today, including RoPieee XL. All of them didn’t go well on Pi 4, with the same popping sound playing DSD. But DietPi and Raspberry Pi OS work fine on Pi 3. I’m even more confused. Now I have a new Pi 4 which didn’t make the upgrade as I expected.

Good for you. Did you change any settings about DSD playback? I set the resync delay, buffer size, but made no difference.

Nope didn’t touch anything.

What are you powering your RPi4 with?

Is there a chance it’s faulty?

I tried two different adapters, one ifi iPower 5V and one Thinkplus 65W PD charger. Both are top players in their fields, I think. :grinning: @lkjhgdaa

Maybe your RPi4 is faulty…

Used both Ropieee and VitOs and didn’t have any issue with DSD (Rpi4 4GB)

I did (a lot) more research, and will try to update RPi firmware. The difference I can tell from system logs of two Pis is the USB controllers, no other error messages matter. The one used in Pi 4, VIA VL805, got a firmware update a couple of months ago.

1 Like

Didn’t work out. The eeprom is the latest. I returned this Pi 4. Maybe buy another Pi 4 2GB to see if the problem persists.

1 Like