What's coming in Roon OS 2.0 (not Roon 2.0, but Roon OS 2.0)?

From the console you can mount the smb share of your Roon ROCK/Nucleus and perform your rsync. The GUI screen shot you posted is a NAS to NAS synchronization feature.

1 Like

for example a simple interface for install extensions?? that are very hard to install?

Thanks @Mikael_Ollars,
I discovered in the meantime the data partition isn’t supposed to be used for storage anyway so my original Q is no longer valid.

1 Like

I thought had read the thread already.

Things on the table (but not yet committed to):

  • extensions
1 Like

Maybe RoonOS 2.0 will never come as it’s not on roadmap?

I like this idea. I’m currently mounting local to run rsync. Having native rsync should make this process quicker and more straightforward. Would be good to add an “rsync account” which can be enabled / disabled and cert protected (at least password).

1 Like

From a non-Linux user perspective I like the simplicity of Roon OS.

I use Robocopy to keep my NAS music folder sync’d with my ROCK.

1 Like

Get a cheap USB SSD and plug that into your NUC
Then schedule an rysnc from your NAS to the USB SSD.
That’s how others and I do it.

This is a good thread for rsync:

1 Like

Maybe I’m a bit stupid but I’m not sure what else Roon OS needs to do.
Very happy with current OS on my NUC. The less I have to interact with it the better.

1 Like

It’s coming because future NUC hardware won’t have legacy boot any more. The question is how does it co-exist alongside existing legacy boot machines? Particularly Nucleus owners who don’t want to be messing with Bios settings.

ROCK in no way forces use of a NUC, even though other hardware isn’t officially supported. You can build up your ideal system using the same Intel processors/chipset that a NUC uses and happily run ROCK on it. I’m currently running ROCK on a 9 year old HP8300 i7-3770.

4 Likes

Indeed MOCK is alive and well

1 Like

You can but that is not officially supported as it is considered tinkering.

Drop support for old hardware and get rid of the old software baggage :sweat_smile:

The old hardware can do UEFI. It is getting people to change bios settings that is the challenge! :wink:

Especially with Nucleus units. The BIOS settings change cannot be automated in an update to my knowledge, and even if it could it would be very risky.

1 Like

Not witnessed them not supporting me and my mock. They might not support RoonOS itself on a mock by Roon it’s not stopped them. There is the caveat that it might stop working due to updates bother are aimed at specific nuc elements.

Only real option I like to see is UEFI boot since all new computers (NUC 11 comes to mind) only allow UEFI boot and legacy boot is disabled. Also if thats the only thing to be added it should be an easy upgrade.

As some others said Roon OS seems to run stable so no real additional features needed which potential mess everything else up.

Said that the NUC has HDMI out (some even 2) and it would be nice to utilize that feature for some info on what’s playing etc.

I also seen some people mentioning running a Linux Distro and Roon Server. Great I tried that and it seems a viable option, however sometimes Roon does not pic up new added tracks and you have reboot Roon. Little combersome on a headless unit to log in and reboot. The current web interface of Roon OS makes that portion very easy. And not to mention configuring Samba Sharing, Firewall rules and mount points if you not familiar with Linux and available flavors.

Currently I am running Windows 11 Pro on a Nuc 11 since its easier to use Remote Desktop and patiently waiting for OS 2.0 with UEFI support

2 Likes

Indeed I just want ROCK UEFI support, UEFI support is so long delayed because the same excuse that old used NUC still circulating in ebay/Amazon so no urge to go for NUC11 and beyond, but I am using 4th Gen i5 ROCK that running hot with 22nm process, with higher electricity billing rate, now the new intel at 10nm that running faster and cooler, and more future proof, but the UEFI support just stop everything from 11th Gen, I tried running on 11th Gen machine with Linux Core but I want to migrate my existing ROCK machine more, so my 11th Gen machine is idling now and waiting for UEFI support.

6 Likes

Perhaps already mentioned (I tried but could not find it), but a memory consumption meter in the web status view might be useful. That is, if future Roon versions will devour close to or even more than the 8GB that were recommended for ROCK when I bought my NUC…I’ve not hit a wall yet, though.