What's going on with my playlists?

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Ethernet, Netgear modem/Netgear switch

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio DirectStream/Bridge II

Description Of Issue
Can’t figure out what’s happened to my playlists. Some stuff is there, some stuff isn’t, but it’s all accessible. Just not to the playlist.

I take it these are streaming service tracks?

No, they’re on my hard drives. As individual albums, everything is playable. But as a playlist, only some stuff is.

Have you tried any basic troubleshooting such as rebooting everything?

Yeah, but I’ll do it again if that’s advised.

Didn’t work. Roon skips right to the next album.

BTW - Roon took much longer to start up than it has been taking. Results are the same, though.

If you click on the track three dot menu does it take you to the right file?

Hi @Dan_Schwartz,

Has there been any recent change to where your music files are stored?

Can you share a screenshot of Settings > Storage?

Aw! That was going to be my next Q.

1 Like

No, the three dot menu doesn’t go anywhere. Not by song, anyway.

Yes, sort of. The drives are the same but they WERE attached to a MacMini. Now they’re attached to a NUC.

I’m honestly not certain if the NUC could see them originally. I think so, but can’t be certain. I think this only happened yesterday. The NUC change happened a few days ago. But what IS certain is that they’re all on the same drive.

Hi @Dan_Schwartz,

Do you have a backup from before the move occurred? Can you try restoring that and share a screenshot of Settings > Storage from that time and I can help make sure we get things migrated properly? Thanks!

You’re looking at it, (I had to restore after I changed to a NUC)EXCEPT that the drive names have been changed by Roon (or something). IE, I had personalized names for the drives and now Roon won’t recognize them, AND it keeps resetting to the generic names. This affects performance to the extent that I now can’t back anything up (because the personalized names are entered into Roon) BUT again, all the tunes are contained within the drives.

I’m considering whether or not to migrate my drives to ExFAT, which I understand Roon prefers, but it would defeat my reasons for getting a NUC in the first place.

This may or may not add to the solution or deepen the mystery. I attempted to start the list further down, and it skipped an entire album again, but this time it said a required CODEC isn’t available, and the album is in MP3 form.

When you setup ROCK, you have to load the mo3 codec yourself into the appropriate folder. The file is ffmpeg, if you review the install documentation, I am sure it discussed this step.

Step 6 in the Rock install guide

I’ve done it, but still the same results.

you need to unzip it twice and then you only copy the file called ffmpeg. You seem to have gotten a folder copied.