When Album selected, no similar music/artists displayed on right side pane

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus, latest build

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Spectrum 150 MBit broadband internet
Ethernet network using NetGear gigabit switches
WIFI - erros network all devices hardwired
Roon Nucleus hardwired to ethernet network
Qobuz subscription.
iPad 7th generation used for Roon Remote

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Kii 3 active speakers with Kii Controller. Roon Nucleus USB connection to Kii Controller.

Description Of Issue

When any album is selected, similar music or artists are not displayed in the right pane as it used to. Any selected album will play, including this selected from Qobuz. No music streaming errors ever occur, including any temporary blips. This happed approximately 2 weeks ago. I’ve been using Roon since January and this feature has always worked before.

I’ve rebooted the Roon Nucleus core many times as I did with the iPad/Roon Remote. The problem still persists.

Hello @Robert_Wohlers, thanks for the information! I have some questions.

  1. Do you have the model number of your switch? I’d like to know if it’s a managed or unmanaged switch
  2. In Roon, under “Overview”, do you have a “New Releases for You” category?

Let me know!

My ethernet switches are Netgear ProSafe GS108 and GS104. These are not managed switches.

On my Roon Remote “Overview” there is no New Releases for You” category.

Hey @Robert_Wohlers,

Interesting, I would suspect that something is blocking your connection to our servers, you should try:

  1. Disabling your VPN (if you have one)
  2. Disabling your Firewall

And see if doing either of those nets a better result for you. If you’re still having issues, give Google or Cloudflare DNS a try and see if that helps!

I know I don’t have a VPN. I’ll research if my router (erro) has an active firewall. My gateway router (eero) acts as the DHCP server for all my network devices. Since I’m using the Roon Nucleus, which is directly connected (hardwired via switch) to the gateway router, I’m assuming that the Roon Core is not blocking any traffic. I will research the eero to determine if it has a firewall. Also, I will determine if I can set the Google DNS IP addresses into the eero. Can this be done for the Roon Nucleus also? If so, how?

I still must ask, since the “similar music and artist” feature was previously working, why should it suddenly stop?

Bob Wohlers

Hey @Robert_Wohlers, thanks for the information, let me know what happens!

As far as “why”, we’ll need more information before we can track down a root cause as there are several factors that could be at play. These could be things like:

  1. A router firmware update
  2. Changes from your ISP

I could find NO firewall settings for m router (eero). I did however change the DNS to Google DNS ( and I verified that the Roon Nucleus was using the new DNS settings - it is. Still no change as I do not get the similar music and/or artists display.

Is there some test I can perform, perhaps on my desktop computer, to determine if the Roon servers can be reached or are being blocked?

Hello @Robert_Wohlers, thanks for the info! So, on any other machine on this network, are your running Plex Media Server? We sometimes have issues if Plex is running elsewhere because both Roon and Plex are sharing a port.

I’d also like to get a screenshot of the issue from you with one of those albums where there should be recommendations.

I am not using the Plex Media server on any of my devices.

Here is the screen-shot. On the right side it shows albums from the SAME artist. It used to show first the albums from similar music/artists then from the same artist.

Hello @Robert_Wohlers, are you experiencing this on remotes other than the iPad you’re using? I’d like to try a different remote or reinstall the iPad Roon app and see if that fixes things. After we’ve tried that, let me know and we’ll enable diagnostics and take a look at what might be happening in the background of this issue.


I downloaded Roon to my MacBook Pro. It exhibits the same behavior as my iPad. I also deleted the app from my iPad and reinstalled it. No change.

Hello @Robert_Wohlers,

I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

Please respond to this thread next time you see this issue and I’ll take a look!


I just finished using my Roon Core, for about 1 hour. Hopefully the diagnostics will reveal the issue.

Hey @Robert_Wohlers,

I’ve discussed what you’re seeing with our team and we wanted to know if you have any issues with Radio Playback. If you haven’t used radio before, you can learn about it here. Give it a try and let me know if you see issues with this feature. That will tell us a lot about what’s going on.

Thanks for your patience on this!

1 Like

Well, that did the trick! I selected an album that should have given me some similar artist/music recommendations. It did not. I then followed the directions to bring up Roon Radio. Roon Radio started playing the first selection from the album and then started showing similar music. I back-arrowed to the selected album and there was the similar artist/music selections back on the right pane where they used to show up! Album after selected album now showed similar artist/music recommendations. Even after I turned off Roon Radio, the similar artist/music recommendations still appeared when selecting albums.

Looks like some internal flag or database setting got reset after I selected Roon Radio. At least that’s my theory. In any case all now is well. Thanks…

1 Like

Hey @Robert_Wohlers, glad things are working again! I passed this information along to our team and they were wondering if you’re using usb 2.0 or 3.0 to connect to your DAC.

I believe the connection is USB 2.0. I’m using the Kii3 Controller (active speakers). The connector looks like a USB 2.0 connector, not USB 3.0.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.