When shuffling Roon halts when it encounters a Tidal track

I have Roon running on an Innuos Zen mini. This feeds 2 Muso QBs and a Devialet Expert Pro via ethernet.
I often just shuffle a bookmark with 10,000+ tracks.
This sometimes works fine.
But other times the shuffle just pauses when a Tidal track is next to play. I have to go to my iPad and just press play.
Any thoughts?
(Also, how do I find the Roon log file on the Innuos?)
Stuart Dudman

Thanks for sharing your report with us, @Stuart_Dudman!

May I ask that you please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

So we can gain some additional insight into what you’re experiencing, please verify the following:

  • Does this only happen when shuffling TIDAL and local content? If you’re just playing TIDAL does this occur?
  • Have you noticed any patterns in when this occurs? Is it a specific sample rate or type of media (i.e. MQA) that seems to trigger the playback stop? Do the same tracks seem to cause the stops, or is it not consistent (i.e. sometimes a track will cause the stop, sometimes it does not).
  • Does this behavior happen for all audio endpoints, or just certain endpoints? Does it happen if you play to a device connected directly to the Core machine?
  • When playback stops do you see any error messages in Roon?
  • Can you share a screenshot of the signal path when playing TIDAL content to one of the affected devices


Setup: Innuos plugged into TP-Link gigabit switch which is fed from Sky router. (Wifi via Orbi). But feed to devices is via ethernet.
I have never tried just Tidal content. I will try that.
I have tried to work out patterns. It may be more common with MQA.
This happens on QB AND Devialet. Thinking about it, I don’t tend to shuffle on the Devialet but the pause still happens sometimes when the queue reaches a Tidal track.
Never seen a Roon error message when this happens (but I don’t know how to find the log file).
Not sure how I would connect directly to the Core machine. Please advise.
Hopefully that png file is the signal path.

Thanks for the details, @Stuart_Dudman!

Do you know the model of this switch? Is it a managed switch?

Please give this a try and let me know the results. This will be a great data point for our troubleshooting. If we can determine if there is any difference in playing just TIDAL content from a mix of TIDAL and local it will help us further narrow down why this behavior may be occurring.

You wouldn’t need to view the logs for this, Roon may display a message box saying “Media loading slowly”, or other similar messages. I don’t think we need to review logs just yet, but for your reference you should be able to access the logs by connecting to the Innuos over the network from a PC or Mac machine. We have more information about this here.

Just to confirm, is Roon and the firmware on all of your devices up to date? Have you tried power cycling your Core machine, endpoints, and networking hardware since noticing this behavior?


Switch is a TL-SG1016. Don’t even know what managed means.
I will set up a Tidal playlist. Luckily I have a tag called Tidal so that’s easy.
Roon tells me I have the latest versions installed. Devialet and Naim up to date. Innuos being updated now.
The problem also occurs over wifi to the Naim boxes thinking about it.
It has always occurred (6 months or so). I’ve only just got on this Roon site. My bad. Core machine is rebooted every week (seems to work better if I do that). Naims and Devialet have been switched on and off many times.
I have seen the Media loading slowly message once, when our broadband seemed bad. Nothing to do with this problem. This is a pause. I just have to press play and we’re off again.

I need a little bit of help here. I have set Tags for a lot of my Tidal albums. But when I select that Tag, the search (I presume an SQL query) just goes away and never comes back. This happens with some of my Tags.
Is there any other way to build a bookmark of just Tidal tracks?
And I guess it would be good to know how to prevent the queries going into a loop.

Hey @Stuart_Dudman,

The easiest way to get only TIDAL tracks is to use Focus.

  1. Click Focus
  2. Choose Inspector (bottom right)
  3. Choose Storage Locations
  4. Choose TIDAL Library

This will display only TIDAL tracks. You can then create a bookmark so you can easily return to this selection.


Fabulous. Wish I’d known about that before adding all those Tags.
Now how do I stop the queries from being never-ending? I need to create a bookmark of Tidal songs acceptable to my wife. I have a JS tag but when selected the search never comes back.

Hey @Stuart_Dudman,

Can you describe exactly what you’re experiencing?

  • How many albums/tracks do you have assigned this tag?
  • Does it happen for all tags, or only specific ones?
  • How are you selecting these tags (from what screen) and what happens when you choose the tag?

If possible can you share a video of what you’re experiencing with the tags?


JS (Jenny and Stuart) has 1240 albums tagged.
I created a video but your system only allows picture uploads. And small files as I just found out.
https://www.dropbox.com/l/scl/AABxbvtLhuBCd2xgVWcay6Dpu_Md54xdn4s So hopefully that link will take you to the file.
You will see I have already focused on Tidal albums only. Now I want just the tracks my wife likes: JS.
I select the Tag and the computer (or phone or iPad) just goes away with that jellyfish moving its tentacles.
I think it happens periodically with the JS tag. It also happened with JUST the Tidal tag (378 items).
It took a long while to set up these tags and for them to stop working is a bit of a blow!

Hey @Stuart_Dudman,

Thanks for sharing that! It appears as though the slowness with the tags you’re experiencing may be related to a similar report that we are currently investigating.

First, I’d like to gather some additional information about the tags that you are using and exactly what you are seeing.

  • You mention that this behavior occurs with the JS tag and the TIDAL tag. Are there any others? How many tags do you have total? Do they all exhibit this behavior?
  • Do albums frequently have multiple tags (i.e. TIDAL and JS)?
  • Are you selecting the tags more frequently from the Albums browser or Track browser? Is there any difference and behavior between the two?
  • Can you give me some details about your library? How many albums and tracks total? Where is the library stored?
  • Do these tags eventually load after some time? If so, how long? Or do they just endlessly load?

Next, so we can do some further investigation, would you be able to send us a copy of your database in a shared Dropbox link? You can send this to me directly in a private message.


Loads of good questions.
I don’t tend to use the Albums browser with tags, just the tracks browser. Nerdily, on shuffle, I am playing my whole collection once. So I bring up all the unplayed JS tags and shuffle on those for instance.
I just tried album browser and the JS tag worked. And Tidal. So it seems to be a Track browser problem.

Every album will eventually be tagged JS or S. Every album will eventually be tagged upnp, Tidal or MQA.
So each album should have 2 tags. Tidal and JS is very common for instance.
I’m pretty sure I’ve seen this behaviour with the S tag, but not right now. MQA has worked every time. And upnp I think.
According to Roon I have 1729 albums. About two thirds are upnp stored on my Innuos Zen mini. The rest are Tidal.
The query never seems to come back. If you like I can leave it running overnight. It’s been running now for 5 minutes or more so I’ll switch it off.
I operate roon from 1 iPhone, 3 iPads and this MacBook. Same behaviour on them all.
Can I just share the Roon backups which are already in Dropbox? If not, you’ll have to let me know how to navigate to the Roon database on the Innuos.

Oh yes. For now if I want to play JS tags I select S and then NOT it (turn it red, -S, however I should describe it). And that works.

Thanks for the detailed response, @Stuart_Dudman!

The backups that you already have in Dropbox should work great. I’ll send that, along with your information provided above, to the team for further investigation.


[link removed by support]
That should be my Roon backups.

Thanks! I’ll pass that along now and I’ll be sure to update you when I receive feedback from the team.


I spent the weekend trying to understand what is going on. I was the world’s worst developer but best software tester.
I now have total replicability on the shuffle/pause problem.
Shuffle works fine until:
Next track is pressed
Add next inserts a track
An MQA track tries to play.
After all of those, Roon then pauses on any future Tidal track. Obviously it pauses immediately on the MQA track, but then on all future Tidal tracks.
The way to stop this is then to start the shuffle afresh.
I think if first track of the shuffle is Tidal, that also causes a pause.
I think I can persuade my wife NOT to divorce me after putting up with my tests. LOL

Thanks for the detailed test results, @Stuart_Dudman!

I’d like to propose another test that should give us some greater insight into where exactly this behavior is stemming from. If you have another machine you can temporarily use as a Core, can you install Roon there any try to replicate this behavior?

If this behavior occurs on the other machine then the behavior is likely caused by networking difficulties. If the other machine doesn’t exhibit this behavior, then we know that there is something specific to this Core that is causing the behavior.


Emails to you (community or dylan) bounce back.
If Dropbox still isn’t working, do you guys have an ftp site?