When will KEF LS50 Wireless II be Roon Ready? [They are now!]

As the update kicked in automatically at some point in time, there’s a chance this could also happen to you. Maybe tomorrow morning it changed!

1 Like

That’s an odd one. A long shot, but if you can, maybe try with LS50WII cabled directly into your router? Just trying to think of easy things to try.

Either ways, pop a log through the app (in the settings tab), and that will filter through to your local customer service team. They’ll be in a much better position than I to assist.

No luck. I did send a request to the customer service team, hopefully they can come back with an answer soon.

My first ever experience with KEF is far from positive so far after buying an expensive speaker set:

  1. First few weeks after purchase no connection with LG oled tv (was fixed with 1.3/1.5)
  2. One speaker stopped working after 4 weeks, had to wait for 5 weeks for a new set.
  3. New set won’t update to the latest firmware version, hence still no use with my tv
  4. No customer service available in the Netherlands, only a webform where with a bit of luck you get an answer after 2(!) weeks.

KEF really need to get their sh*t together: asking a premium price for a mediocre product and service.

Sent you a PM, Rene.

Hi Ben, I have the same problem :slight_smile: Hope you will PM me too

5 posts were split to a new topic: LS50 Wireless II & Home Automation

2 posts were split to a new topic: Does anyone use a power conditioner with their LS50W2?

Ok Ok, April and KEF’s “Roon Ready” isn’t here yet. But my personal Solution for “Roon Ready” -after a lot of testing- is, and I’m proudly presenting it here:

Ingredients:

  • Deskmini 310 with 8core i7-9700 32GB RAM, 500GB M.2, 2x2TB HD
  • running macOS Big Sur with Roon 1.8 Server and
  • HQPlayer 4.x upsampling everything to DSD or PCM768
  • RaspBerry Pi 4 as NAA (DietPi, RoonBridge & HQP NAA) feeding:
  • S.M.S.L M500 ESS Sabre DAC - 512DSD or 768 PCM via USB
  • M500 AUX-out to AUX-in of KEF LS50 Wireless II
  • Controller: Mac mini M1 - iPhone 12 Pro Max - iPad mini - iPad Pro 11

Not exactly cheap nor Plug and Play like the LS50 should be, but the Sound of this Setup is WOW, I may stay with this setting and only switch for convenience listening via Airplay or TV-HDMI, everything else from ROON with Qobuz (gave up on TIDAL) will go over the above chain for best in class listening. Also great for Headphone-only Listening with the M500 DAC!

So, no Solution for everyone but I’m Happy with it for now.

That kind of defeats the simplicity of going with the LS50W2 in the first place. I’d rather just wait a couple weeks than jump thru hoops with many unneeded extra boxes.

2 Likes

Exactly my thought. I changed over to the KEF LS50W2’s to stop my constant urge for trying different configurations. April is the month of moment of truth.

As long as you’re happy.

Yeah, I don’t get it at all. Is chromecast really that bad???

The Raspberry Pi 4 has two micro HDMI outputs, and the KEF LS Wireless 2 also has HDMI. According to the Rasberry Pi documentation, you can select HDMI for the audio output. But I can’t see a specification for the quality. (e.g. eARC-compatible HDMI ports can deliver 24bit/192kHz.)

Have you tried connecting directly from the Pi4 to the LS50W II?

I looked into it with Ropieee and it doesn’t allow the hdmi port on the rpi4 to be used. Not sure if another OS allows it though. But also then MQA isn’t unfolded, that only works with a networked input.

The Pi’s onboard audio (mini jack and HDMI) still uses PWM. It’s not just not very good – it’s bad. Pretty bad. That – and the HDMI port on the LS50WII is designed for an (e)ARC connection to a television – it does not accept regular audio.

Chromecast is fine. But not gapless. And of course it does not play nice with other RAAT zones.

Ok thanks for the update. From what you and Rene have said, HDMI isn’t a solution from the RPi 4! Just have to hope that KEF/Roon come up with the goods some time in April!

I’m sure they will.

I was about to make an Aprils fool joke saying the new firmware was out … but I decided to behave … Guess I’m becoming mature …

3 Likes

Funny enough, it was the first thing in the morning: to check is the update is already available. Unfortunately it is not…

1 Like

just joked about this on twitter.

2 Likes