Where are all the setting gone too

Hi after updating to the new 1.8 version, I’m missing the settings only see the general settings, when using the Windows pc cliënt. Can’t find them anymore after the update.

They’re there, I just saw that they are having Server issues over in Roon land, so it appears that so many people upgraded it’s overloaded their server capacity. I’m just guessing your a victim, I’m on Win10 PC, just try again in a bit or perhaps re-start everything:

Hi GeoB,

After a complete reboot and 8h later tabs are still not there, so it looks like a client bug.
I have understood that this is a know issue if your pc language isn’t set to English.


Try setting the default language to English until there is a fix in.
It’s a known work around.

Hi Henri,

My cliënt language is in English, not sure if it is the default however I tried Dutch same problem. Good to know this is a known bug, for me the work arround is using my mobile cliënts.


Changing my PC system language to English did solve the issue.

1 Like

Settings on IPad (latest version) will take me back to main IPAD screen
Rebooted Rock / IPAD did not resolve the issue - also radio stations lost

I have the same issue, my system language is German. Changing the language to English is a short-term workaround and is OK for me for a few days, but this bug should really be fixed as soon as possible!