Where has my System Output gone?

Core Machine (Operating system/System info/Roon build number)

Windows 10 Pro x64 v1903 / Intel i9 9900K CPU PC, 32 GB Memory, Roon Core installed on SSD / Core v1.6 build 169

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired (1Gb/s) ethernet distributed around premises via various Netgear unmanaged switches. WiFi 2.4 and 5 GHz available for mobile devices.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

System Device Realtek HD (optical) to Logitech 5.1 powered Speaker system. Two Sonos devices in other rooms, WiFi from wired Sonos Bridge. Other computers on network have access to Logitech speakers via a 4 by 1 optical audio switch.

Description Of Issue

Have been a Roon user for a few months without much activity. My music is all on a Buffalo Link Station NAS (4 x 1TB drive RAID 5 array) and is sourced from mp3 and HD FLAC downloads, CD and Vinyl rips to FLAC. The ripping process for Vinyl disks is progressing slowly. Currently my library contains about 13,000 tracks.

Yesterday I was looking into how I can integrate my HiFi home theatre system into the Roon environment and my initial thought is to use a Sonos Connect. In the meantime I was using Roon Radio to play track selections from the library. I loved it!

Today I wanted to do the same thing but my System Output was not available as an end device despite rebooting Roon and the PC. The Two Sonos devices were available and working well but that was not much assistance to me in my office. I then installed RoonBridge on another PC and I can now see that PC’s System Output and so I can play my files locally through that PC (as long as it is running).

Why can’t my Roon Core see my System Output? It is working because I can play files with MediaMonkey or VLC - no problem. Help

1 Like


Was it there and has disappreared or has it never shown up?
Is the System Output enabled in Settings or does it not even show there to be enabled?

It was there yesterday but not today. It also does not appear under Settings…Audio. The other networked computer (using RoonBridge) appears there with its System Output enabled

Make sure you use the latest driver for the Realtek HD.

Hi @Bob_Hutchison,

As mentioned above, definitely make sure that your drivers are fully up to date. Also try disabling the firewall on this machine temporarily — Does it show up when you do this?

Thanks @BlackJack, I have had a look at the Realtek HD Audio drivers and they are the latest from Microsoft dated March 18, 2019. These came with the latest release of Windows 10 (1903) recently and are on both computers. I doubt that the drivers are an issue because (i) they were working on this PC 24 hrs previously with no driver change, (ii) audio still works on this PC using different programs (VLC, MediaMonkey) and (iii) audio System Output works on another PC with the same Realtek drivers using RoonBridge.
I have a spare Asus Xonar sound card which I will install on this PC to see what happens.
@dylan. I have tried disabling Windows Defender firewall and that made no change to the problem. Roon.exe and RaatServer.exe have been approved to go through the firewall anyway.
My latest attempt to overcome the issue involved reinstalling the latest version of Roon over the top of the existing version - didn’t fix it!
Any other ideas?

Have you tried using a new cable? I think the Asus test will be interesting.

Hi @Bob_Hutchison,

Definitely let us know how this goes!

It would also be interesting to know if the same behavior occurs with a fresh database — Please see these steps:

  • Make a Backup of your current Roon Database
  • Close Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

OK It has been a couple of days of testing here.

The main finding was that I can recover my system output only by performing a clean reinstall of Roon with a new database as suggested by @dylan. The first session of Roon following the install is fine in all respects - I can select from among any of 4 system audio devices on this PC (all Realtek) and they work well for as long as that session exists and in testing I have run it for more than 24 hours.

When I close that Roon session and then restart I ALWAYS lose the system output. If I am very quick and go to Settings…Audio I can see all four audio options for “Connected to this PC” at the top of the list of available devices and the default system output is attempting to enable. Within a few seconds all four of those options disappear from the screen leaving a gaping hole. Clicking the refresh button gives me the Roon Working dialog box which never closes or achieves anything.

Closing and opening Roon at this point will never bring back the System Output. I can bring it back, and have done so many times, by uninstalling Roon completely (including the database) and then reinstalling it. But again I only get system output for the first Roon session.

There was also the question of using an Asus Xonar sound card on the PC. After a full reinstall of Xonar and Roon I see 8 devices on this PC and I can play through the Xonar perfectly well for the first session. It, however, also disappears after the first session.

Having given up on PC1 I have de-authorised the Core and installed Roon on PC2 which is an old i7-3930K (6 core 12 thread) computer which does heavy lifting on video encoding most days running at 100% CPU utilization. Roon seems to be working perfectly well on this PC using only 4% CPU. I have opened and closed it many times without losing system output.

So it would seem that there is some interaction on PC1 between Roon and something else. I don’t have a clue. Would support get anything out of the log files?

Thanks for the detailed test findings, @Bob_Hutchison.

Moving forward, I’m hoping you can try the following:

  1. Make a backup of Roon
  2. Navigate to the RAATServer folder in the same directory as the Roon folder
  3. Rename RAATServer to RAATServer_Old
  4. Launch Roon and confirm if System Output appears
  5. If System Output appears, try closing and re-launching Roon — Make a note of the time that you do so
  6. Check to see if System Output appears in Roon — Make a note of the time that you open the Settings > Audio screen
  7. If it’s gone again, respond here with the times in steps 5 and 6 and we will enable diagnostics to take a closer look


Thanks @dylan, I will move Roon from PC2, where it now resides and is performing OK, back to PC1 when I have some spare time. In the meantime I have gone back to PC1 and examined the RAATServer directory which seems to have survived all the complete uninstalls of Roon that I had done. It seems to keep the last 20 logs for Roon sessions and I can clearly identify those where System Output failed or succeeded.

For all sessions the first 60 odd lines were effectively identical. In all the failed sessions the last 2 lines in the log file were similar to below with only the timestamps changing between sessions:

08/16 10:54:30 Trace: [RAAT::System Output] [output/alsa] enable_mqa_usb_device_support=1
08/16 10:54:40 Trace: [RAATServer] refreshing @ 10s

Whilst for a successful session the log passes the ALSA driver statement and carried on with statements about the System Output initialization:

08/16 10:53:03 Trace: [RAAT::System Output] [output/alsa] enable_mqa_usb_device_support=1
08/16 10:53:03 Trace: [RAAT::System Output] [output/wasapi] [ASUS Xonar D2X Audio Device] supports PCM format 44100/16/1
08/16 10:53:03 Trace: [RAAT::System Output] [output/wasapi] [ASUS Xonar D2X Audio Device] supports PCM format 48000/16/1
08/16 10:53:03 Trace: [RAAT::System Output] [output/wasapi] [ASUS Xonar D2X Audio Device] supports PCM format 96000/16/1
and so on…

It is clear in the above cases I was using the Xonar sound card as my default Output Device. Does this give you some clues? I am happy to send you the complete files if it would help.

Just another point for your further reference. In Windows 10 systems (at least) the Roon and RAATServer directories are protected from modification including renaming by the operation system. To get at these directories you need log in with different credentials or with a different OS. I use a Windows PE environment to change the directory names.

Thanks again

Hi @Bob_Hutchison,

Thanks, Bob — Definitely let us know when you’ve been able to do so.

If you would, please do send the logs over to us via a shared Dropbox link and we can take a look. Thanks!

I think I sent a PM with dropbox links

Hi @Bob_Hutchison,

Can you try disabling the ASUS soundcard in Device Manager and then reboot and let us know if things work after that?

Hi @dylan

You might recall that I only installed the Asus soundcard originally to see if that fixed the problem with the previous Realtek inbuilt audio processor. It didn’t and now I have disabled Asus, made Realtek the default again, but still have no System Output. Do you want a set of files?


Did you remove the Realtek drivers when you did the Asus test. Try removing all traces of the Realtek drivers and install Microsoft HD audio drivers instead. Remember to look for and also remove all traces of the Nahimic drivers.

Thanks @Rugby
To test the Asus Xonar sound card theory all I did was to install the card and the latest software from the Asus web site. Then I just picked the optical output of the Xonar card as my default output sound device. I did no uninstall process on the Realtek.

Anyway all this is a bit moot now as I have found and corrected the problem. You gave me the clue with “Nahimic drivers”. I had never heard the name before and went looking for references to it on my system. There were many!

In particular there was an automatic running service “Nahimic service”. When I stopped the service and ran Roon my System Output once again became available. It didn’t matter whether I was using Xonar or Realtek output device as System Output. I was able to reintroduce the problem at will by starting the service again. Now I have got Nahimic service on Manual start and not running. All seems well!

It looks like Nahimic is inimical to Roon functionality.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.