Where is startup drive from within Roon

Roon 1.5 on Mac OS 10.14 working fine. But how do I find the Mac’s startup drive from within the Roon settings? Music is on internal storage on Nucleus. I can choose backup from within settings to backup to a NAS or to Dropbox, but what if I want to backup to a folder on the startup HD. How do I type a path that works to get back to that drive? If I use the path like “users/myusername/music” I just get an error. Tried prefixes, tried user and password or not.

You can’t backup to the Nucleus boot/startup drive. You shouldn’t backup to the second internal drive. That should be kept as music files only.

Suggest you run your Roon scheduled database and settings backup and point them to a drive on another system, a NAS, or to a 32Gb USB3 flash drive connected to the Nucleus.

You’ll need to share a designated folder in your Mac on your network first, then add it as a network share in the Roon Backup screen.

I am sharing a folder on my Mac, but within the Roon Backup screen I get an error every time I try to type a pathway. Adding a network share works fine to my NAS, but that’s not where I wanted to backup.
“You can’t backup to the Nucleus startup drive.” Isn’t the startup drive within the Nucleus? Are you saying I can’t backup data to my Mac? (which then would be again backed up by Time Machine and cloud service)

A few things are getting confused here, so I’ll try and clear them up.

The boot/system drive of the Nucleus is for the Roon software system and it’s database and settings. You run the Roon backup procedures to back this stuff up to other drives. You don’t get to write the backups to this drive.

The second internal drive with a Nucleus is meant for storage of your music files. While you could get the Roon backup procedures to write the backup files to this drive, you shouldn’t. (I had been doing this until recently, but was advised by Roon support not to continue to do so.)

The scheduled Roon database and settings backups can be written to many other places.

On my two setups I run two two daily backups on each. On both, the first daily backups are written to a 32Gb USB3 flash drive on each system. On one, the second daily backup is written to the NAS where the music files are stored. On the other, the second daily backup is written to the external USB3 hard drive where the music files are stored. (Other backup procedures then backup these storage areas.)

You can point the Roon scheduled backups to be written to a drive on your Mac. I’m not a Mac user so I know not how to do this. Others can guide you on how to do it.

Hey @Richard_Gutknecht,

What error are you getting? Can you share a screenshot of this? What is the path you are entering to the shared folder on the Mac?

“You can point the Roon scheduled backups to be written to a drive on your Mac.”

Yes, that’s my original question. No, I’m not trying to back up to the Nucleus core or to the internal storage drive on the Nucleus. But within the Roon software settings, I can’t see my computer HD. As my screen shot shows, I can back up to my NAS and to Dropbox, but that’s what I did when I couldn’t find my computer through the settings. (Is this to do with my Mac not selected as the core? But I’m not sure what that means.) Am I trying to add a network share only to the NAS that is showing up? How do I see the Mac?

I think the problem lies in your network share location string: According to the example and Apple website it should be something like this: smb://ServerName/ShareName where you replace the Servername and Sharename as appropriate.

Perhaps your screenshot is just being used as an example, but in the screenshot you appear to be intending to use the default Music folder as the location for your Roon backup.

Even if you haven’t set this folder up as a watched folder in Roon (because you are using an internal storage drive on Nucleus), it’s perhaps not a good idea to use the Music folder to hold backups of your Roon database.

Sometime in the future you may want to add the Music folder as an additional watched folder, and forgotten that it also holds backups.

Best practice is not to store Roon backups in folders that contain music files being watched by Roon.

You won’t see the local mac harddrive from the remote software on your mac as it’s connected to nucleus as that’s your core and that does the backup not your Mac. Remotes doesnt see your local hardware. So the backup directories need to be entered as a SMB network path to the folder you are sharing on the Mac like you do for a NAS.

Hey @Richard_Gutknecht,

As Geoff mentions above, it may be better to create a different location than the Music folder to store your backups. I would recommend creating a new folder on the Mac for this, setting up the sharing properly, and then using that folder for your backups.

As mentioned above, the path should be in the following format: smb://ServerName/ShareName. You will also need to make sure you enter the proper username and password for the share.

Let me know if you have any questions!

Thank you for the info that remotes won’t see the local hardware and that smb is required, but I’m still stuck with my original question. I have tried every pathway permutation I can think of and always get “unexpected error” when I try to get to the mac.
I have set up network shared folders on the mac and tried to use them. I’ll change the name so no one will be concerned about backing up to a music folder. (Music is on internal Nucleus storage and works fine.) Easy to backup the actual music itself from internal storage because with CCC I am able to choose any destination including the mac.
I tried to add a share both with and without user and password filled in, for example

smb://imac-8447.local/users/rick/documents/roontestbackup
smb://imac-8447/users/rick/documents/roontestbackup
smb://macintoshHD/users/rick/documents/roontestbackup

What am I doing wrong?

Step-by-step:

  • Do you have File Sharing enabled in System Preferences > Sharing?
  • Have you added the folder you want to share to the Shared Folders list (like Documents in this example):

  • Have you set Windows File Sharing in Options?

If all is right, you should now be able to connect using

smb://imac-8447/Documents

(If Documents is the Shared Folder).

1 Like

Sharing is enabled for the test folder, and I didn’t know about the options, but windows sharing is enable by default.

Hey @Richard_Gutknecht,

Can you confirm that the “rick” user has the correct permissions? You can see this in the first screenshot from Rene above.

Are you able to access that test folder over SMB from another machine?

Yes, I seem to have the permissions, and yes, I can access that test file from another mac.

Hi Rick,

Can you try adding the .local after 8447 in the Network Share?

image https://roon-community-uploads.s3.amazonaws.com/original/3X/d/1/d16e985d484ac6faaa80374cb69dddc9fc274ddf.png

Ie. smb://iMac-8447.local/documents/roontestbackup

Cheers, Greg

Just some guessing about the screenshots posted in this thread:


grafik
Please try using smb://imac-8447.lan/ instead of smb://imac-8447/.

grafik
grafik
Using rick instead of Rick might or might not work (Sorry I’m not a Mac-user).
Just to be save, please use Rick and try again.

Now I’ve tried .lan, and I’ve already tried .local, and I’ve used Rick instead of rick, though I don’t think that matters on Mac. And I tried the 6331 computer name (don’t know why there are two numbers.

Under Windows a share gets published under it’s share name. It doesn’t matter if it’s actually a sub folder of a folder on a drive. Assuming that the folder name is used as share name …
grafik
I would suggest you try smb://imac-8447.lan/Roontestbackup.

If that fails … does MacOS have some sort of event log that you could check?

1 Like