Where to set my router Public IP- connecting remote using Roon ARC

I’m trying to connect remotely via ARC. But I can’t find a configuration under roon or roon ARC that allows me to define my routers public IP,

Need help.

Roon Core Machine

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

It’s because you don’t need to.
My understanding is that when your Roon core connects to Roon servers, your public IP is stored on Roon servers. Then when Roon Arc connects to your account on Roon servers, it will be able to retrieve your Roon core’s stored public IP.

1 Like

Yeah I found out , for some reason it is hitting my firewall but not being processed …

Will update once I figure it out.

Please visit Roon Remote > Settings > Roon ARC, and share the diagnostics message. Thanks.

Issue resolved by correcting NAT.


My audio server runs on a diff subnet than my wifi where I use my phone to command tracks and it works just fine . Not sure why documentation says dual subnet is not supported .

Howmany users can use ARC to stream remotely ? It seems unlimited as it does not over lap users

Roon Remotes and the Roon core need to be on the same subnet. This has always been a requirement. The core discovers endpoints and control devices.

I’ll mark this thread solved since ARC is working for you.

Roon ARC is intended for use outside the network. Fort forwarding is used to connect public IP to the core, and this can traverse subnets if correctly configured.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.