Which HQP Filter are you using?

Sadly the PC I have access to is not working. I’m still looking for other options.

Was using the filter poly-sinc-gauss and poly-sinc-gauss-hires-Ip and I noticed it won’t play any sound for MQA 48kHz

So I try using the iFi Streamer alone, and it was OK playing the file sound.

So tested the MQA filters, and I was able to hear the file very good, but a random 1-2 sec pause happen, like at the middle or beginning of song. Usually will be only once per song. And happens while playing MQA Tidle files.

Any suggestions? @IgorSki @jussi_laako @Chunhao_Lee

Have you disabled Roon’s MQA decoding?

Also check that you don’t have “48k DSD” enabled, and that you don’t have “Adaptive output rate” enabled either.

1 Like

Disabled, no 48k DSD, Adaptive output rate was grey, now off. Still jumping.

When I enable “MQA render only”, it happens less often, like in some songs yes in others no.

1 Like

You should have MQA decoding active, so that HQPlayer gets 88.2k or 96k data in, MQA decoding should be visible in the Roon signal path.

Are you running out of CPU power?

1 Like

Testing it now, sounds good so far. A little more forward than the gauss filters, and a little more latency.

Btw @jussi_laako when I turned off “Adaptive” for Sinc-LI HQPlayer desktop crashed (up-sampling to DSD256 with ASMD7ec). Using Windows 10 (not that it matters much, I probably want adaptive on anyway).

1 Like

I assume this on latest 4.19.2 version? I’ll check if I can reproduce and fix it.

Hi @jussi_laako I’ve already activated the MQA (updated theme to Dark)

I’m able to play all of the MQA songs now with other filters (that sound amazing) and you can see MQA decoding signal path

The music still randomly will pause for 1 sec, and if I play the same song that had the pause, it may not pause at all again. For example the song below after 31-sec playing, it pauses for 1 second and then continues. This was also not happening to me before the latest update. I’m recording the logs if you need to dig in more.

The Roon HQPlayer MQA capabities settings aren’t right. HQPlayer is not a decoder or renderer. I don’t use Roon, but the settings don’t look correct to me.


Your Signal Path is showing that Roon is not doing the first Decode. I think you now have to go in and turn on MQA decoding on teh Audio Devices Advanced Setup page if you want it to decode MQA.

1 Like

You need to keep MQA Core Decoder enabled, and then tell that HQPlayer doesn’t have decoding or rendering capabilities.

These are my Roon - HQPlayer settings:

1 Like

Jussi: Are you actually running Roon into a 5.1 channel setup? I note you have it set up that way, but I recalled your using 2-channel DACs.

I have two multichannel DACs. exaSound e28 and Merging Hapi.

But even if I use stereo DAC, I want to get 5.1 to HQPlayer which I use to perform stereo mixdown when necessary. I don’t want Roon doing any mixing or other messing with multichannel material.

For example HQPlayer can perform 5.1 channel DSD64 → 2.0 channel DSD256 and headphone EQ at the same time, all running at the source rate without extra conversions.


Ok :+1:t2: many thanks! Let me update

I’ve made updates. On Flac files the pause is less frequently on MQA, still happening by the end of the music. I have a laptop with M1 processor to test if needed.

I found the issue, I had the ifi Zen in all in one (all services enabled) instead of Only NAA mode.

Still happening but now after 15min of listening :ear: to MQA files. Just a half second drop.
You can see my cpu and signal path.

Finally found the reason, bad Ethernet cable and usb cable. Totally unrelated to software. Using simple not fancy Ethernet


Here’s also one example of Hapi use case.

First two channels connected to my pre-amp for loudspeakers (channels 1 & 2). Next two channels connected to Ferrum Oor for the headphone system. HQPlayer is configured to output 4 channels (Unicast connection through ANEMAN), and HQPlayer matrix processor is routing the two source channels to these four output channels. The second two channels get headphone EQ for AKG K601. And I can easily switch between loudspeakers and headphones on the fly. HQPlayer processing four ASDM7ECv2 modulators to DSD256 on 9900KS, no GPU offload, no drop-outs.

In this case, HQPlayer is running in a different room and HQPlayer Client is running on my Linux desktop and playing Qobuz. Hapi and rest of the audio gear two meters away.

(Qobuz playlist: New in Electronic)


Will the 8 GB raspberry will be a best choice for dedicated NAA? (Not shown, but I guess is same processor as 4GB?)

Will reply in the NAA thread. Let’s keep this thread for the favourite filters discussion.

1 Like

Also why we are on the topic, there is a known issue with Roon resetting the Enable MQA core decoder setting on devices upon restarting the service back to “off”. Ticket has been filed, and the workaround is to set your device as a renderer only (instead of no MQA support) as this will save your settings after the Roon Core process restarts.

I’ve been noticing it the past couple of days on my devices, and manually fixing each time I restart Roon. I’m setting up the workaround now (Note: if you have your device set up as @jussi_laako outlined above you will run into the issue if you restart the Roon core service - reboot the server, update etc.)