White Noise When Upsampling Hi Res to DSD


My set up includes: HQPlayer/Roon/mR as NAA/Bricasti M1SE Dac. I encounter white noise when attempting to upsample 192k to DSD, but not 44 to DSD. Furthermore, if i remove Roon from the chain and control HQPlayer (running on macmini i7 2.3ghz 16g, SSD, El Capitan) via screenshare, the white noise stops.

I’ve found a few other posts concerning white noise, but the circumstances are different from mine. I understand it could be an issue with how my dac interprets DoP and trying to convert it back to PCM. But if that’s the case, why does some DSD upsampled work?

I’ve also tried removing mR from the chain and connect direct via usb (control via Roon)… still getting white noise for hi res upsampling. This makes me suspect it’s something with Roon.

Here are my settings:

Thank you in advance,

Hi Udi,

I wasn’t able to see your setting pix, would you mind uploading them into your message using the “bar and arrow up” icon in the editor menu ?

Hi Andy,

Here they are.

Cheers, Greg

Thanks for the setting information.


Since PCM -> DSD works well for 44.1K, I suspect you may have a problem for non
integer multiples of the original sample rate.

Make sure you are on the latest version of HQP (3.14.3)

Couple of things you can try:

  1. Try an integer multiple for Bit rate limit: 6144000 or 3072000
  2. Check if it works by choosing ‘Auto rate family’

Hope this helps.


thank you. I tried different integer multiplier and it appears that white noise has stopped. However, now i hear some stuttering… should i try a different integer?

Stuttering could indicate you do not have enough processing power. I would suggest starting with the smallest integer multiple and working upwards.

Other things that I have used int the past and has helped:

  1. Uncheck Pipeline-SDM
  2. Try increasing buffer time (I leave mine at 200 ms for ASIO drivers)