White screen, slow

I am having great difficulties trying to get Roon/MacMini to pass the sound through to my AVR Receiver without modifying it in High Sierra, so I thought I would try bootcamp because I never had these problems in Windows (I just prefer the Mac). Bear in mind I had already sold my mid 2011 MacMini because the AVR could not handle its signal, so a few days ago I got a late 2012 model only to find that in Windows 10 Roon runs badly and presents me witha white screen after minimizing it. I messed with it for the best part of a day only to run into a message on this site from two years ago saying this is a known problem with the GPL driver of the Intel 4000 chip (also in my model) and it cannot be helped. I tried the latest Intel driver … without success.

This is very frustrating. Would a downgrade to Windows 7 resolve the issue (please no speculation). Is there anyone out there who runs W7 on a PC with the Intel 4000 chip and has no issues with Roon? Should I just throw in the towel and buy a third machine just to accommodate Roon?

Have you tried the Roon 32bit client?

No I have not because the old discussion had some Roon employees arguing against that option. But I am so desperate at the moment I am happy to try that. Considering I already have the 64 bit client installed what would be the best way of going back to the 32 bit client? Simply install it in addition to the 64 bit one?

Nice try but no go. I uninstalled the 64 bit version, installed the 64 bit server and the 32 bit client and have exactly the same problem. After minimizing Roon comes up as a white screen.

@support flagging the Roon boys and see if they have any suggestions

Hey @Luke23,

Thank you for sharing your report with us. I would like to apologize for the difficulties you’ve been experiencing here. Upon review of your report and current setup, it appears that the issue is definitely stemming from the Intel GPU that is being utilized on your machine.

In the past we have seen these Intel GPUs, the 4000 in particular, have difficulties with OpenGL. You can read about this in more detail here, but Roon is dependent on OpenGL to operate. In systems with multiple GPU’s, we’ve seen improvements when people “force” Roon to use the non-Intel GPU, as described here. We know that’s not an option for everyone, but it has helped some of the reports of this issue we’ve seen.

I am having great difficulties trying to get Roon/MacMini to pass the sound through to my AVR Receiver without modifying it in High Sierra

May I ask that you please go into a little more detail for me here? How is the AVR connected to Roon? What exactly is happening when you try to play to it? How does that differ from Windows?


Certainly windows will be having perhaps be the culprit here. You didn’t try the whole core/remote as 32bit?

Still can’t load a JPEG image but the late 2012 macmini is Intel HD 4000 chipset

Thanks for replying. I have seen the discussion on the Intel 4000 and in a MacMini there is only one chip, so that’s an end of that. What did make things slightly better is that by using the 32 bit client instead of the 64 bit one, the album art now loads fast, but the white screen problem has not been solved.

As to my audio problems, that is actually a different thread. Would you mind looking here: Surround sound on MacMini where I will try to explain what I have learned about sound on a MacMini.

Some good news. On my MacMini (late 2012) bootcamp I downgraded from W10 to W7 (64bit) and installed the Roon 32 bit client. It looks as if the white screen problem has disappeared. I can minimise the window and it will come back up fine. There are also no more delays. In fact Roon is very snappy indeed. This suggests the older W7 drivers have no problem with the Intel 4000 chip. I wonder if the 64 bit client will also work?

Assuming your win7 is 64bit then might be worth a shot. Not sure if it would work 64bit app on 32bit os…

But the 32bit client has worked for many with slow artwork issues on both 7 and 10 versions

The 64 bit client does work too, even after my W7 bootcamp updated itself to SP1.

1 Like