Why are some songs without sound? (TIDAL, MQA)

Hi All, just installed a complete ROON set-up and have a strange issue where it intermittently looks like songs are playing, but no sound is produced. This happens mostly with Tidal based music. I have been looking on the forum posts, but can’t find a similar issue.

It happens when you select another album to play where then the album seems to play or when you are in a Tidal playlist suddenly song no 5 and/or 9 doesn’t play, but the program shows the song progressing as normal. The ROON screen shows the playtime bar progressing and acts as if nothing is wrong nor is there any different indication in colour buttons or playback info. With MQA music the light shows on the DAC, but no sound. Again, when playing a Tidal playlist it happily plays the next song after the ‘non playing’ song has finished.

I did note that when there is no sound playing only the blue light on the DAC lights to indicate MQA, but no white lights are lit to show bit rate.

With this complete new set-up I’m puzzled where to start looking. I feel it is somewhere in the Rasp Pi, the Meridian DAC or the interaction between the two (or based on how ROON processes/channels MQA music, but then would expect more erratic, not song-linked issues).

Appreciate your thoughts!

Thanks, Rene


Server - HP 8300 SFF with i5 and 4Gb. 128Gb SS hard disk. Ubuntu server and latest ROON server build. No music storage connected directly.
Storage - QNAP NAS
End point - Raspberry Pi 3 with DietPi and latest ROON endpoint installed. Meridian Explorer 2 DAC connected.
Network - hardwired with DHCP

1 Like

Hi @Rene_Zwart ------ Thank you for the report and sharing your feedback with us.

Moving forward, we are going to be doing some testing in house to see what we can come up with in regard to this behavior you’ve reported. Once I have some feedback I will be sure to update this thread accordingly. Your patience is appreciated!


Hi Eric, thanks, much appreciated. Do let me know if you need more info.

If I find an album that doesn’t play I’ll start listing them.

Brgds, René

Hi @Rene_Zwart ---- Thank you for your patience while I have been discussing the next steps here with the team.

Moving forward, we would like to see if we can replicate this behavior in house. Is it possible for you to provide me with an example of TIDAL content you are noticing this behavior with? A URL would be very appreciated :sunglasses:


Hi Eric, I’d be happy to, but how do I send you the URL when I select an album in Tidal? I’m not selecting it through a browser, but through your interface.

Brgds, René

1 Like

Hi @Rene_Zwart ---- Thanks for touching base and pointing that out to me. Can you provide a few examples of searchable content that you’ve noticed this behavior with?


Hi Eric, just experienced it again.

Tidal playlist “Indie Excellence, Vol.1” both No 12 and 13 result in no sound, but a single blue light on the Explorer2. No. 14 starts to play again as if nothing happened, showing a blue and a white light. No.15 is again not playing.

It’s almost as if the MQA flag reaches the Expl2, but not the actual music stream. However I was in the understanding you can’t have one without the other…but what do I know about that :slight_smile:

Brgds, Rene

I tried to include a screen print, but can’t do it, it seems.

On Tidal Masters “Indie Excellence, Vol. 2” Song 1 plays, 2 & 3 no sound, 4 plays, 5 no sound,6,7,8,9,10 all the same, but 11 then plays again. :frowning:

Brgds, Rene

I’ve bumped your forum account’s “Trust Level” up a notch … you should be able to now.

Nope, still doesn’t work.

Hi @Rene_Zwart ---- Just touching base to let you know that I have seen you’re follow up (thank you).

I will let you know what the team comes up with. Your patience is very appreciated!


Your understanding is correct–you can’t have one without the other. If the Explorer2 is lighting the blue light, it’s confirming that the stream is authenticated–meaning it proves the audio stream including the MQA data is arriving intact and unmodified.

Just in case, I replicated your setup here. Explorer2, DietPi, Linux Core. I am not having these symptoms.

But–since the Explorer2 is authenticating the stream, it stands to reason that the problem is somewhere downstream of that point, and not back in Roon. It’s definitely worth contacting Meridian to ask how the device could both authenticate an MQA stream + play silence at the same time :slight_smile:

This is what I’m seeing for the device firmware on the Explorer2 here. Maybe you have a different version and could try upgrading/downgrading in case this is a firmware bug?

1 Like

Hi Brian, thanks for coming back on this. I tend to agree and will contact Meridian. If anything comes of it I’ll let you know.

Brgds, Rene

Hi, I’m in contact with Meridian, but they haven’t yet responded yet on that except for making sure that I had the latest drivers installed (which I had, but redid the installation anyway). Will revert. Brgds, Rene

This is one of the albums that often fails to play. At the moment all screens look like normal play with movement of the time bar etc. This time the Explorer2 only shows a singly white light, although the song to be playing is MQA

Meantime I have reinstalled the DietPi software & the roon bridge on the RPI, but no luck here.

Setup as before - Roon server on a HP SFF desktop, all hardwired over two switches (Smart? no management) between the router and the RPI. Explorer2 connected to RPI through a jitterbug.

Brgds, Rene

Meantime problem remains.

Hi @Rene_Zwart ---- Thank you for the follow up and my apologies for the slow response.

Did Meridian ever get back to you in regard to this behavior?


Having a similar issue: MQA albums either don’t play using the Tidal ap(I just get an endlessly spinning “wheel” in Tidal where the play/pause button is; or, the album “plays” but I get no sound,I’m not getting the blue light with the Meridian Explorer2, updated drivers.

All non-MQA albums play fine thru the Tidal app.

Hi Al. Meridian requested to do some further testing on another computer, which is what i now did;

I have done some further testing and somehow feel it probably has to be an issue with the E2.

I have connected the E2 to the computer that runs the Roon core (running Ubuntu latest long support version) and noted similar behaviors. The E2 was then connected to a different audio system all together.

I tested with some Tidal MQA playlists and had in the original set-up as well as directly connected to the core same music not playing. I noted another interesting thing (?) in that when the playlist jumps to the next song the blue light momentarily goes off and comes on again when the next song starts to play (as per Roon indication), however some of those songs don’t produce sound.

Regretfully I have not got a lot of MQA music myself (only some 2L songs) to test the unit without Roon over multiple music ranges (bit depth etc.), so I’m a bit at a dead end here.

The fact that with some songs the MQA flag comes on, but no sound and a next song could then play again makes me feel that Roon is working as expected, but for whatever reason the E2 doesn’t want to play some of it.

Is there anything I can test further?

Brgds, Rene

I uninstalled Meridian driver and Tidal app.

Restarted computer.

Reinstalled both apps after downloading most updated versions.
Problem solved.