Why can't my PC Play in Remote

I have recently moved my Core to a NUC/ROCK. My desktop sees the new core an allows me to manipulate , Edit etc BUT I cannot see the internal sound card/speakers to play locally

Any Ideas , what am I missing

Hi Mike, I’m guessing your checked this but is the player portion of the PC enabled in the Setting - Audio?

Could it be a firewall issue?

Hi Mike yes checked both ,I checked everything I can think of before posting.

the desktop is the one that was running my core until the NUC ROCK , I expected it just to show up the local speakers BUT :pensive:

Does “this PC” show up in settings/audio? or in settings/about? If not, try disabling firewall and see what happens? If the local stuff shows up after your disable you may need to add roon and raatserver to the exceptions.

Also, verify that your PC is on the same subnet in the network as the ROCK.

Also, look here:

It’s certainly on the same subnet and both Roon.exe and RAAT are excluded from the firewall. I must admit I thought I had checked these.

I’ll try disabling he firewall

Thanks for the suggestions

Doing a search for this on the forums I see several instances of this issue. One said to open task manger and kill the RAATserver process and then start roon the devices showed up. Of course he said he has to do this each time before starting Roon, so not ideal but as a workaround…

Just tried Firewall off , no effect. RAAT and Roon are both in the exception List

I reboot the NUC every day (we have major lightening storms so anything sensitive is disconnected from the mains daily)

Roon is running as an app, not started at Windows startup. I can close Roon at will still no effect.

One thought , starting Roon “app” for a remote use also starts the RAAT server , can I stop that somehow ? There is no library on the PC in question NOW but there was . I have uninstalled and reinstalled Roon .

When this PC was the core the speakers showed up no problem.

That’s why I am confused

What options do appear in Settings - Audio - for This PC that Roon can see?

Is it possible some configuration option needs to be modified in the PC?

Sorry, lots of guessing from this end. I don’t recall any issues such as this when I switched from PC to NUC but it has been 2.5 years. I only use PC/Laptop for Roon remote now and none of the options are enabled.

Yeah, give us some screenshots to look at…

As for the RAATserver, I see it in my task manager and it has not caused issues. You can try end teh task in task manger, but it will probaly come back the next time you start Roon.

Settings Audio shows just the RPi 4 with Riopeee, no sign of any other devices.

There is just one active device on the network , the RPi

The core is visible from 2 x iPads on 2 iOS versions

I’ll try the Realtek driver update that @Rugby suggested in a PM, incidentally I had to do this my wife’s PC to restore audio after the last windows update

this is Settings>Audio

Allo Digione is thr RPi 4

The MyGica is my video streamer , also Airplay compliant

But No PC Speaker output

Reinstalled drivers no joy

Got it , there were 2 RAAT entries in Firewall , Private and Public , the Private was unchecked

Thanks To All :heart_eyes_cat:


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.