Why does Roon downsample when my DAC supports the format? [Solved]

Hi all,

I have a support question. I have some 24-bit 192 kHz FLAC files. My DAC supports this sample rate. In settings I have set Max Sample Rate (PCM) to 192 kHz (same result when I set to Disabled).

Still Roon is performing sample rate conversion 192 kHz to 48 kHz.

How can I make sure that Roon doesn’t perform any Sample Rate Conversion when my DAC supports the format?

This is on RoonServer running on a Mac Mini.

Many thanks

Hi Foxmoon,

@bplexico reported the same thing recently with a Mac Mini running RoonServer. Does your Signal Path also show a “Sample Rate Conversion” item between Source and Output ?

That shouldn’t be happening with Max Sample Rate set to either Disable or 192 kHz. I wasn’t able to replicate the problem on a Brix running RoonServer under Windows 2012r2.

Barr said it was an intermittent issue for him; you might find it occurs sometimes and not at others. Anything you can add about when it seems to occur will help squash it.

In the meantime let’s ask @mike or @brian if it’s a known issue and see if we can get a fix in the works.

Thanks for the reply andybox.

Yes, signal path shows “sample rate conversion 192 kHz to 48 kHz”.

Not intermittent, always get the same SRC when playing 192/24 or 96/24.

44.1/16 plays lossless (no SRC).

Also, on my iMac which is connected with a optical out to a receiver that supports 96/24 I get as output “RoonSpeakers Streaming” and not “CoreAudio Exclusive Mode”. I cannot determine what and if any SRC is being used, although it does say 96/24 source material is “lossless” and 192/24 material is “high quality”.

The receiver connected to your iMac is a private zone and “RoonSpeakers Streaming” is a usual description for private zones. It’s a subset of the planned full RoonSpeakers protocol that enables remotes (such as your iMac) to use endpoints connected to them. Nothing unusual there and it sounds like there is no SRC happening except down to 96/24. Does the receiver have a display indicating what input it is receiving ?

On the Mac Mini you could try toggling exclusive mode, event driven mode and integer mode (if present) on and off in Output Settings. Try some DSD files and see if they get played as expected. Sometimes those things can flush out gremlins.

When Mike or Brian come by they’ll take up a more detailed analysis and probably get some logs from you.



None of my DACs display incoming bit/sample rates unfortunately.

When I toggle exclusive mode off the output changes to OS Mixer with a green dot next to it (I assume this is NOT bit-perfect/loss-less again).

Exclusive mode on and integer mode off I get SRC to 48 kHz again (same as exclusive mode on and integer mode on).

Thanks again

@foxmoon - Try going into the Utilities folder on the Mac Mini running RoonServer. Open Audio Midi Setup - look for your DAC in the list and set the Source to max sample rate of your DAC ( 192 ) and the other setting to 2ch-24 bit integer.

Then restart RoonServer.

Roon always tries to start a stream at the native rate first. If your DAC or driver says “no”, then it progressively backs off to easier formats. So if it’s resampling, then the DAC or driver refused to play the audio stream.

One of the most common reasons that this happens is if you had another exclusive mode app consuming the device and tried to play a certain format through Roon. Roon remembers (and bans) failed configurations for the duration of the application run, so that it doesn’t waste too time trying them later–so one failure is enough to cause that format to be resampled until the app is restarted.

If you’re still seeing this reboot after a reboot, and with no other apps vying for your audio device, it might be useful to pull logs and look at exactly how the DAC/driver are saying “no” to Roon.

A couple of quick questions just to clarify. You have an iMac attached to a receiver that supports 24/96 AND a DAC which supports 24/192? And both are down sampling? Are you connecting both via Toslink Optical?

Toslink Optical is sketchy at 24/192. It usually is not rated for that resolution because it is flaky. Sometimes it works, sometimes it doesn’t and is very cable dependent. Try a different Toslink cable and see if it makes a difference. Also, verify the specs of the output optical connector of the iMac and the optical inputs of the receivers to make sure that they can also accept 24/192 via toslink. Some connectors are not rated that high.


  1. I have a Mac Mini running RoonServer. The Mac Mini has a DAC attached to it through USB. This DAC supports up to 192/24.

  2. I have an iMac running Roon. The iMac is attached to a receiver that has a DAC chip inside that supports up to 96/24. The receiver is connected through toslink optical.


1 Like

Think I narrowed the problem down. On the Mac Mini in Audio MIDI Setup the maximum rate I can select for the USB DAC is 48 kHZ, 16-bit 2 ch. Which is strange because the DAC is a Schiit Bifrost that is capable of up to 192/24.

1 Like

Alright so restarting the DAC (didn’t help) and then re-inserting the USB cable on the Mac Mini seemed to have solved the issue. I restarted Roon, the device I configured earlier was gone so I needed to reconfigure the USB DAC in Settings but now I’m up and running in full resolution (purple’ish dot and no SRC).

Many thanks for all your replies.

What audio output are you using in Roon audio settings ? If system output then you get whatever setting your system is at. Suggest look for your connected DAC and select that.
I don’t use Mac but others can confirm exact details.

All good and hope you’re enjoying it.

Well worth remembering the “pull it out and plug it in again” tactic for Mac Mini users and possibly others; it probably causes a new handshake so the DAC can remind the OS what sampling rates it can support for Audio Midi.

Precisely. That and also resetting the Dac. So many options with more to come, i.e., roon with TIDAL (HIFI); and with Dirac Live; roon with AsQ+with iRC and EQ (16 settings).

Enjoy the music,