Why does Roon "lose" and then keep reloading my Library?

Quite strange - Roon apparently loses track of my Library (on NAS) and then begins the process of reloading again. This has happened several times in the last day. Playback is also intermittent - I’ll have an album on looped play (repeat) but it will just stop after a few tracks. Any suggestions? Thanks

I just had this happen to me a little while back. It is reloading now. I too am using a NAS ( Synology) and I mount it directly to my desktop. I did the initial load this morning, all good for about 11 hours and then I notice a reload in progress. Apologies to mods as I posted this as a new issue and then just stumbled across this post.

No issues with playback yet.

Hi @bobolaclune and @bplexico , we’re very familiar with this issue and I can tell you it’s because your NAS is mounted via AFP, not SMB. AFP is an unreliable protocol and in the next build we’ll be preventing users from importing files from a NAS that’s mounted via AFP.

To make sure your NAS is running the SMB protocol, enable Microsoft Networking on your NAS, and disable Apple Networking.

Remove your old watched folder in Roon and add the new one in the network path under settings / storage like this: smb://IP address of your NAS/Music directory

Reply cross posted here.

Thanks Kevin, you are quite right. I am a Mac user with a Synology NAS using Apple File sharing . I’ve switched that and started Windows FS. I am being told the path to use as smb://NameofmyNAS and the system doesn’t like that path . I also have the IP address but I am not sure how to integrate the name of my NAS and the IP address. Roon also gives me the option of adding it as a local folder through the “Browse” feature and doing that seems to work since I can navigate to the NAS which shows up in my Finder. Is this an OK way to operate or should I go the Network Folder route? If the latter , could you help me with the smb input details?

Thanks

1 Like

Not Kevin, but since I am having the same issue with a Mac and a Synology NAS.

  1. Here is what you would input as a Network path in Roon:

smb://10.0.1.201/music

You would substitute your IP address for the one I have listed. And you would substitute the name of your music folder for “music”

I would also like verification that using the mounted NAS drive on my desktop as a local folder won’t work ( it doesn’t appear to as my library re-loads ).

Lastly I did change to a network drive using SMB, but left on Mac File Services as well as Windows File Service, and it worked for a while but this morning I found Roon was again re importing my full library.

So just would like confirmation that my only option for using Roon with my NAS on my Mac is with Mac File Services turned off.