Why doesn't Roon show the correct track titles?

I have a HD-Download of The Magic Flute in my library.
Obviously this album is correctly identified by Roon.

The album has 46 tracks. The problem is, that they all appear with the same text string ‘Die Zauberflöte (The Magic Flute), opera, K. 620’.

Roon shows the correct track title only at the bottom of the screen in the playback row.

I tried anything to solve this problem, without success. I repeated the album identification several times (By the way, the Qobuz-Version has the same problem). I tried the album editor:

I tried the track editor:


Is anybody out there to solve this problem?

Walter, I’ve moved your post into the Metadata Issues category of the forum.

My copy showed the same, I have Work/Composition and Part/Movement set correctly , I just changed to Prefer File

You will need to edit the Tags external to Roon, no way within Roon

Set Composition as Zauberflote
Set Part/ Movement to Track title
Set Work part Prefer file

Quite pain :face_with_monocle:

Hi @Walter_Horn,

As suggested above, you can fix this by using WORK/PART tags and preferring file tags for this album. I’ve also reached out to our metadata provider as it looks like this is stemming from a lack of data on their side. I’ll be sure to follow up once I’ve heard from them.

Hallo Mike,

thanks for your reply.

The tags have been edited external to Roon. They are correct.
Seems that it is Roon who has a problem.

I just did it and it now shows correct

The metadata source Roon is using is dodgy. If your Tags are good go to Edit> Metadata> Work Part>Prefer File

Does that not work, it did for me ?

Hi @Walter_Horn,

Our metadata provider has let us know that they have corrected this today. Please give this about a week or two to be reflected within Roon. Once you see the change on your end please mark this post as the solution.

Thanks again for your report!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.