Why has all the album art disappeared on every device?

Roon Core Machine

Intel NUC, devices are mostly Max

Networking Gear & Setup Details

NAS, wifi sometimes, all devices connected to ethernet, no VPN

Connected Audio Devices


Number of Tracks in Library

? 10,000

Description of Issue

Album art disappeared about three months ago. Reloaded every operating system, rebooted everything. Even Tidal album art is gone. It all worked for years without a problem. So what gives?

Do you know if this coincides with any drivers updates as it does sound like a potential graphics driver issue.

Nope, no driver updates. It’s every device. Started happening around June. Deeply frustrating.

And you don’t have a “metadata improver paused” warning at all?

No, I have not seen or heard of that. Essentially this started on its own - and when I opened a device which hadn’t used Roon for a while, all the album art showed up, then deleted itself. I’ve even tried re-installing the entire library.

@roonsupport - can you please help here (offline is ok!)

What OS are you using on the NUC, is it a ROCK installation, Windows or Linux?

Could you also give more details about your network setup? The more information you give to @support, the easier it will be for them to diagnose the cause of your issue. Thanks.

The NUC is a dedicated Intel, Linux / ROCK. Not being a techie I’m not sure what else to add on the network. There is a Pakedge switch connecting incoming internet to the NUC and to many devices via ethernet. But the problem is with wifi-connected iPads (x3), iPhones, and Macs. Storage is a QNAP NAS - but I have zero artwork for anything either stored or from Tidal, so not sure if that’s an issue either.

It all disappeared about 3-4 months ago and while you occasionally get one image popping up it’s all blank.

Er, is this a switch or did you mean a Pakedge router?

Per email - it’s a switch, we have the Fios routers. But I don’t understand why it would be a network issue. Roon works - just the album art (and Tidal art) doesn’t.

These screenshots give you a sense of it. Anyone from Roon Labs can help here?

Since all the artwork resides on the Roon server, I think, it sounds to me you have lost your connection to Roon. Is your Roon account in good order? Have you tried signing out and back into Roon?

Hi, fellow user here.

It might be an ipv6 issue, can you try to disable ipv6 on the router?

Hi @angus_oshea,

Thank you for reporting your issue. Let’s see if we can get that fixed! Try these steps and let me know if your issue is fixed. If not we can dig deeper.

  • Exit out of Roon
  • Find and open your Roon database
  • Navigate to Roon/Cache
  • Move the contents of the /Cache folder elsewhere, like your desktop
  • Try restarting Roon and verify if the issue still occurs



Here’s a potentially easier fix too. In Roon under settings>setup try clearing the image cache.

Let me know how it goes.


So the only thing that worked was rebuilding the database. Lost all customized content but ok. (Tried all the above with no luck.)

Then: 2.0 came out, updated itself on all devices, but like everyone else, my intel NUC is “not compatible”. Unlike fixes on screen: it does have access to the internet. So now no music at all. Beyond frustrating since there’s no obvious answer a non-techie could ever work out.

Hi @angus_oshea,

I enabled diagnostics and I’m seeing authentication errors when Roon tries to access your storage. Please do check your storage and backup locations and verify the authentication is working right.

Unfortunately, what happened to you was an issue we identified this weekend where Roon Nucleus is erroneously updated to a lower version. Here is the message we sent to those reporting this issue and attached below is the knowledge base article needed to resolve this.

We’ve identified an issue with our update server erroneously serving 1.8 Legacy builds when it was not supposed to, and have since corrected this behavior.

For those who have already been downgraded to Legacy 1.8 and wish to re-install Roon 2.0 on their Cores, please follow the 2.0 migration guide on our knowledge base, linked below.

1.8 Legacy is compatible with 2.0, so your Roon database should remain intact. If you encounter any further issues after following the guide, please start a new support topic and let us know, thank you!
  1. Go to the /Data/ share (instructions) and create a folder called branches

  2. Download the following file: roon_2-0 (It should be named roon_2-0 and saved with no file extension)

  3. Copy the file into the branches folder previously created

  4. Rename the file to roon (instructions on how to rename files: Windows / MacOS)

  5. In the Web Interface, click “Reinstall” under Operating System

When you are done, you should have a file called roon in the branches folder like so:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.