Why is Roon broken so much since 1.6

#74

Same here. No issues at all.

–MD

#75

Is there a way to downgrade to the last stable and updated version of 1.5?

(Ged) #76

No, has been asked before.

(Dan Herrmann) #77

just tried, again with Elvis Costello. The response was immediate on a Windows 10 laptop. Tried it on my iPad, and it too was immediate.

I have 100/100 internet from Verizon FiOS, and my server is a Windows 10 PC.

#78

Same responsiveness after 5 times searching for Elvis Costello?

(Vincent Kennedy) #79

By “search”, I mean after using the search function, clicking on the result and then going to the Performer page. Once at the Performer page, the content there on the Performer page is slow to load.

(Philip Kent) #80

I am having similar problems to those reported above. Search becomes very slow indeed. Unusable in fact. I have Tidal but not Qobuz. I am based in Hong Kong. I can “fix” the issue by toggling my ROCK off and back on again. Presumably that clears some sort of cache. After a while the problem comes back again. I do not think it’s a network issue. Everything else works fine.

1 Like
(Dom) #81

Meanwhile I am truly getting annoyed, I have Roon with Tidal and searching my library has become soooo slow. Adding new albums and identifying is ridiculously slow. Restarting the Core seems to help for a while, but then it starts to drag again. One of the main reasons for me switching to Roon was the fast search. Now it is nearly unusable.
But the first responses from Roon - ah this cannot be, we have so many happy customers without a problem - just really bugs me, seems to be the automatic response whenever something unplanned happens.
1.5 was what made me buy lifetime, 1.6 the first release was the reason I wondered if I had made the right decision, the version we are running at the moment has become awful.
Sitting at dinner yesterday just wanting to choose an album to play in the background was nearly impossible - this for 500 USD playing my very own musicfiles. Come on Roon, get your act together.

3 Likes
(Mehul) #82

I have the same thing. Except I’m using Qobuz alone and not Tidal. Reboot fixes it everytime fro a short while.

#83

Same here: after 1.6 slow searches … and I mean slooooow (not 1-5 secs), also slow access (music on Synology NAS). Yes I use Qobuz (no Tidal anymore). Things have become so bad my wife is pestering me to go back to Sonos. I therefore tried the reboot and set the SMB on the Synology to min and max 2.0. It seems to have improved things, but it is early days.

1 Like
(John Aiello) #84

I was curious about this since I never seem to experience any issues with Roon so I selected a title at random and did a search on the artist name. My response was instantaneous. I tried it several times and then tried another artist and then another all with the same result. I use both Tidal and Qobuz and my library is 3108 albums and 37107 tracks. Not sure why others are having issues. My core is running on a QNP TVS-471 which is powered by an i3 with 16GB of RAM and all my endpoints are wired. The only wireless connection I use is from my iPad to select music while sitting on the couch. I can tell you that a month or so ago I had problems with the installed memory in my QNAP and had to revert for a while to the original 4GB that came with my QNP and things slowed down noticeably. Could it be that those folks experiencing issues are doing so on underpowered machines or those with wireless connections? Roon has a spec that some people seem proud that they are able to bypass and run anyway so I am curious if those same people are the ones with the issues? Sorry if the question offended you. I am just asking.

(Scott G) #85

I don’t think so. This seems like an intermittent problem that can crop up anywhere.
I had some episodes of slow responses early after 1.6 and wrote them off to other changes in my system. Then nothing but great service for a couple of weeks. Now some searches hang for a long time.
My core (NUC8i7BEH ROCK) is hardwired to the switch and serves an ethernet RoonBridge to my DAC. So no soft spots, other than 1.6, Qobuz and Tidal all bunched together.

1 Like
(Fernando Pereira) #86

I’ve had occasional big slowdowns in search and in adding to my library from Qobuz. My core is an i5-7300 with 8GB main memory, 120GB M2 SSD. Music files are on a Synology NAS. Everything is hardwired, managed by a Unifi EdgeRouter. I have good, stable network connectivity. My suspicion is that there’s a caching problem either locally or in Roon’s servers. This tweet thread I read recently is worth pondering.

(Horst P. Beck) #87

Hello all, there is for sure an issue with 1.6 .

Using a nucleus+ the searches will not work properly from iOS devices (wlan) , my office computer (mac mini 2018) , which is connected via cat7 cable, is also slower than before .

rgds hpb

(Aurel) #88

Hey @support, do you have an answer or a documentation for that terrific problem?

(Richard van Enteren) #89

I also use a Synology NAS but still using Tidal. I have now installed Roon Server on my Mac-Mini with the same library and that did the trick for now. Not as fast as it was before 1.6. But the strangest thing is when I now switch to my Synology NAS it’s also faster again. I’m a lifetime member of Roon so hope they will fix this and focus more on stability than more and more fancy new functionality gadgets.

#90

Personally I believe the problem is not the searching itself or network related to the core as the logs show this to be lightning fast and return results in miliseconds. It’s sending and displaying the info on the remote that seems to be stalling somewhere. Support have already hinted that it might be the remote side of things where the issue lies in my support ticket as I brought it up. So maybe the changes made to search on the core has had some knock on effect to the remote software.

One thing people need to understand this is a real issue effecting a lot more users now and more are adding to this thread daily, seems to be rolling along like the XMOS bug did it took a change in Roon to highlight it more.

Somethings changed in Roon that’s caused this, it’s not all the time it’s very intermittent I can be using it and it be perfectly happy for hours then bam it gets slower then bam it goes. It will then comeback and be fine. It’s happening across a massive array of hardware to Nucleus’, NUCs,NAS all of which are up to spec. I know my network is solid I have spent a long time researching and building it, WiFi is only part of the remote chain and my internet has been solid. The fact that when Roon decides to go slow, I can still search in Tidal and Qobuz and my Plex server perfectly fine as does Netflix and all things streaming.

3 Likes
(Aurel) #91

I agree with you, CrystalGipsy.

1 Like
(Dom) #92

Well it is too many people now that wrote about issues. I personally have not got an underpowered machine - bought it in december using the info from the knowledge base. As I wrote before - and many others also, the problem was not apparent in 1.5. Which was still on all our hardware only a pretty short while ago. So I really don’t believe people downgraded their hardware since then, just to be able to have a little rant here.
Guess you are one of the lucky ones, that has not been affected. Maybe it affects people who add musicfiles to their library, instead of only streaming. Who knows, but there is an issue with Roon 1.6 (the latest release)

Reminds me of when loads of my covers were changed automatically after the upgrade to 1.6. In the beginning there were all these people writing, oh no this cannot be - mine are perfect. So I felt like a delusional ranter and there were some rather unkind remarks, until magically more and more people had the issue and it turned into a real thing. Why there always seem to be groups of users (even with nucleus+) that have issues and others don’t, I have not the faintest idea. Just guess that coding software is probably more complicated than we all think, with so many variables out there, that can change behaviour.

This hinting that it is the users own fault, just because oneself has no issue - is a bit too easy and not really helpful.

3 Likes
(Steve) #93

Yes I will add to this thread. 1.6 has brought issues that I did not have before it.
The main one being the slow searches
Secondly unable to get back to the album when in the playing now screen.
Also sometimes album art takes forever to load

Is Roon acknowledging these issues and looking at them ?

Just to add the problems are bad this morning …album art not loading at all

1 Like