Why Is Roon Combining Tracks With .1/.2 Filenames?

Core Machine

Synology DS218+
Roon 1.8 (build 790)
DB stored on USB SSD

Client: Roon 1.8 (790) Mac Catalina

Network Details

Google Nest Wifi (mesh)
Synology connected to router via ethernet

Audio Devices

Raspberry Pi 4
RopieeeXL (via wifi)
USB → Schiit Modi
RCA → Schiit Magni

Description of Issue

This is the first time I’ve run across this issue, and it may be very specific. I was recently updating all of the Radiohead “MINIDISK [HACKED]” tracks (the official Bandcamp release with 18 discs) in Roon and noticed that it’s handling some tracks very oddly: It’s taking two tracks with the same name but “.1” and “.2” in their filenames and combining them into one track (screen caps below), resulting in the one track playing both of the others together and with an aggregate total time of both. At first I thought maybe this was some way of displaying classical movements? I don’t have any classical music in my library so I don’t have a way to compare.

Here are the four files it’s combining into two single files (one for each track name):

9-05 Karma Police 9.1.flac
9-06 Karma Police 9.2.flac
9-10 Let Down 9.2.flac
9-11 Let Down 9.3.flac

Any way to tell Roon not to combine these types of tracks? I’m not seeing anything in Settings. Thanks!

Because Roon uses WORK/PART information on compositions as supplied from third-party metadata sources (for identified albums only?) or tries to reconstruct WORK/PART information from the track title (for unidentified albums only?). Uses colon from my example (and as it seems points from your example?) as delimiters.


Here a (quite useful) example out of my library for an unidentified album:

If this is unwanted for your example, choose “Disable multi-part compositions on this album” in the album editor at the bottom.

1 Like

Thanks @BlackJack, that’s the setting I wasn’t finding, works perfectly. Now the tracks are showing up correctly (correctly from my perspective, anyway :slight_smile: ).

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.