Why is Roon not playing?

Roon Core Machine

2Windows 10 PCs so far, with modern AMD processors and 32 GB+ of RAM.

Networking Gear & Setup Details

Netgear dumb switches and Google Fiber wireless mesh APs

Connected Audio Devices

Core media PC is currently speakerless but has built in sound card and Rift connected. Listening slave PC is connected to McIntosh d150 preamp with DAC, amp, and speakers.

Number of Tracks in Library

50,000 tracks

Description of Issue

Slave PC connected to stereo will not play music with Roon. Other software on the PC like VLC plays fine. I can get the master server PC to play music, but I want the slave PCs to play too! What am I doing wrong? Sorry newbie here this is my first day of Roon.

Have you install Roon or Roon Bridge on the second PC? Have you enabled the audio devices for this PC on your Roon Core under Settings > Audio?

I installed Roon on the second PC and told the name of my Roon server. I enabled the sound card on the Roon server and it plays music when I connect headphones. The problem is on the second PC. When I try to select an output device on the second PC inRoon settings, I can only see devices on the core PC! I can’t see the sound card in the second PC, or the attached McIntosh dac and stereo equipment.

Please confirm what Roon software you installed on each PC, i.e., Roon, Roon Server or Roon Bridge.

I installed Roon software on the first PC (where most of my music is) and selected it as my Roon media server. I’m not sure which version of Roon is on the 2nd PC. It was the same download; there is only 1? Which version of Roon should be installed on each PC?

OK, the first PC with all the stored music has Roon Core Server on it as well as the Roon Play software. The 2nd PC, connected to playback equipment has the Roon Play app. And I’m not able to find its output device (“McIntosh-HD HS USB Audio”) as a choice in either PC’s Roon software. And if I select “system output” (the only output choice) for the second PC, the first PC starts playing!

On the 2nd PC have you gone into Roon’s settings audio and enabled the local devices you require?

That’s what I’m not able to do. The 2nd PC’s sound cards don’t show up as options in its Roon software. And if I choose the default device, music starts playing on the other computer!

Have you signed in to Roon on the second PC and connected to the Core on the first computer? If it’s running headless, you should have installed Roon Bridge. This is why you were asked to state what you have installed; not understanding your setup, it is difficult to provide clear guidance.

I installed Roon Bridge on the 2nd computer as well. Yes I signed into Roon on the second PC and I can see my Roon server, its music, and its output devices. But I can’t see the output devices on the second computer to select them. Other software on that computer defaults to my McIntosh preamp as the default audio device but Roon does not. It can only see the output devices on the first computer, which seems downright weird!

I don’t know if this is causing your problem, but unless you are running both Server and Roon (i.e. not Roon Bridge, but the complete Roon) on the same machine for a reason, you don’t need both.

The Roon software has Server contained in it. Some people run both, but most people do it out of confusion.

My suggestion is that you drop Server, as an experiment, and just use the Roon software on the first PC. Connect the second PC to that, as an experiment, to see it that makes a difference.

Could it be that some other audio software (VLC?) is in exclusive control of the sound card and so then Roon can’t see it?

.sjb

That makes sense; after all confusion has been the leading reason for most of what I’ve done today. OK, I’m removing all but one copy of Roon from each computer . . .

1 Like

Just make sure it is the complete package, what the Roon download site simply calls, ‘Roon’.

1 Like

Whew! Thanks for all the advice guys. Ok, I reinstalled Roon on the second PC, but as the server now. And it works fine, playing through the McIntosh dac and the attached amp and speakers. Disabled firewalls on all machines and put Roon on the other PCs. They can all connect to the server and play along. I can see my music playing in Roon on all the PCs, apparently happily and synced. But . . .

there’s no sound output! Only the new Roon core server is actually playing music. All the other PCs are silent, with outputs apparently muted. I can see them playing along, but not hear them. What on earth am I doing wrong?

Hmm, I would think that you would want the first PC, i.e. the one with the stored music, to be running Core. Don’t know if that is what’s causing your problems, but it seems like you’re still tangled up in your shorts. :neutral_face:

If I was looking over your shoulder, I would have you -

  1. Install the complete package, i.e. what the download site calls ‘Roon’ on the first PC, the one with all your music.
  2. Install the complete Roon on the second PC, or if you just want the second PC to act as an endpoint, i.e. no Control function, then Roon Bridge will be sufficient there. Either way, it doesn’t matter.
  3. Set the first PC to be Core.
  4. Enable the second PC, with DAC turned on, in Settings–>Audio.

All I can envision now, but that should be GTG.

When all else fails, read the manual. :slightly_smiling_face:

I don’t know what this means.

Screen print your Settings->About.

This is what mine looks like -

This topic was automatically closed after 20 hours. New replies are no longer allowed.