Why is Roon on iPhone upsampling everything to 48kHz?


(Roman Pacheco) #1

Core Machine (Operating system/System info/Roon build number)

MacOS Mojave
Roon 1.6 build 401 stable (64 bit)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

iPhone XS
IOS 12.2
No connections (just playing through phone speakers to keep things simple, although I see the symptoms either way)

Description Of Issue

When I play music on Roon via my iPhone XS, I am not using any DSP enhancements (all are off), yet I see that my signal path is altered with a Bit Depth Conversion from 16 bit to 64 bit Float, then a Sample Rate Conversion from 44.1kHz to 48kHz, then a Bit Depth Conversion back to 24 bit.

When I play through my iPad Pro (2018), none of this happens to my signal path. Can you help me understand why this is happening?

Thanks.


(Roman Pacheco) #2

Here is a screen shot of the signal path


(John) #3

Hello @Roman_Pacheco1,

The iOS native system output is locked to a sample rate of 48kHz. If you connect a USB DAC to the iOS device, Roon will be able to send the DAC the native sample rate of the media.

-John


(Roman Pacheco) #5

Thanks @john, but I have iOS on iPad Pro as well and it doesn’t do this. I can provide screenshots of the behavior from iPad Pro (which is that it retains the lossless signal without any bit conversion or sample conversion)


#6

Interesting. I just checked, and like you’re seeing, it doesn’t happen on my iPad mini 2, but it does happen on my iPhone 6s (played the same track).


(Noris) #7

Hi @Roman_Pacheco1,

I am able to reproduce this behavior on my end as well. We believe this is an iPad issue where the correct native sample rate is not being reported by the iPad itself:

Thanks,
Noris


#8

I don’t think that’s what we’re talking about here. On IPad, music seems to play correctly (ie no bit/sample conversation). But on iPhone, the bit rate/sample rate is being converted despite no DSP being used.

At least with mine, either way it sounds fine, though puzzling why this is happening.


(Noris) #9

Hi @Saturn94,

Seeing the DSP conversion to 48Khz is the correct behavior here, since the iPhone’s native sample rate is 48Khz and the iPad should be following this as well, but it is not:

– Noris


#10

Ah, did not know that. Thanks for the clarification. :slightly_smiling_face:


(Roman Pacheco) #11

Makes sense. @noris is there some way to update Roon to recognize that an iPad is misreporting this value (since the specification is for 48kHz) so that Roon will then adjust the signal path accordingly?


(Roman Pacheco) #12

At the end of the day I just want the signal path reporting and adjustments to be accurate and consistent


(Noris) #13

Hi @Roman_Pacheco1,

This is actually what is happening here. The iPad is reporting that the native sample rate is 44.1KHz, so Roon is accurately displaying and using this info, even though it is not correct.

Roon relies on devices reporting the correct native sample rate capabilites, so I would not consider this a Roon-specific issue but rather an issue that Apple needs to address and to update the sample rate to the correct one.

If you’d like, you can go in to the iPad’s DSP settings and enable Sample Rate Conversion and set it to the Max PCM Rate. This will convert the 44.1KHz source stream to 48KHz (which should be the iPad’s native sample rate) and this will be reflected in the signal path.

Thanks,
Noris