Why is this happening again? 😭

Core Machine (Operating system/System info/Roon build number)

Windows 10/i7 6700k 16GB/latest build(I think, if Roon would work I could check it.)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Ethernet 60mb connection -> modem -> AirPort Extreme -> Netgear GS105 -> Server

Server -> Netgear GS105 -> AirPort Extreme -> RPi 4 -> Dac

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Mytek 192 DSD -> USB

Description Of Issue

Why is this happening again?

woke up and server was down, restarted it and these shenanigans happened (again I should say).
I experienced this problem when I installed Win10N and couldn’t get Roon to work, a few years ago I tried to get support about it but no cigar. after hours trying I went with the regular Win10 and no problems till today.

why is this happening out of the blue? at least RopieeeXL working with airplay as it is supposed to :+1: :+1::+1: shout out to @spockfish

Hi @BoyZonderman,

We have some information about codec issues here in our KB. These types of errors can occur if the codecs that Roon requires are not found on the Core machine. Generally, for Windows, these codecs should already be installed.

If you haven’t already, try giving the Core machine a reboot and check to see if there are any updates. If you’re still having issues, follow the instructions in the link above to make sure that the media packs are properly installed.

Roon Server was working like it should less than 5 hours ago, how is it possible those codecs can’t be found and when I try to reinstall It won’t work anymore.
without these codecs Roon doesn’t work or open.

have done this already. no cigar
from my experience only solution is reinstall windows… kinda fed up with this! this is a problem for many years and known for at least as many! would have expected that there would be a better solution after this time.

thank you for your fast reply, none the less!

anymore options to try?

here you can find my previous topic

to be clear, Roonserver has worked for more than a year without problems, this happened overnight

By chance, did a Windows Update occur yesterday?


thanks Mike, latest version 1903 was released in may 2019 if im correct.
can’t find out if any small updates have been installed, i always update manually, my server can’t restart on its own and there have been no power outages.

it seems the updates have happened last week



kinda sad if this broke Roon, especially with this problem and with the regular (non N) windows 10(those codecs are included in the regular (non N) Windows 10.

Maybe try to Restore Windows 10 to an earlier date like a few days or a week ago.

Launch the command prompt. Type - rstrui and then hit enter.

This should launch the System Restore app. Restore it to a earlier date.

Theoretically this should undo changes made to the OS.

Hope this helps.

Thank you very much for your help, this is something I can work with!!

I will try this and keep you updated!

im disappointed by Roon support, this has been a long problem and still no solution to the codec issue. next to that if I would like to troubleshoot and tinker about these problems and more I would use a free program like plex or Volumio.

right now I have to invest a lot more of my precious time into something that just has to work :sob:

Didn’t work unfortunately, but thanks anyway

Did the restore say it was successful or did it say it failed.


no system sec has been disabled and that’s why it can’t restore.

and what is even more bad is that that codec prompt pop ups every 10 sec making the server unusable to a degree

Hi @BoyZonderman,

Can you share a screenshot of what version of Windows you’re running? It should look something like this:


Hi Dylan, this is a strange situation. as you can see Win10N pro has been installed, but I never installed Win10N pro because it doesn’t/ I couldn’t get it to work with those bloody codecs.
in the end I gave up and installed regular non N win10.

I’m not quite sure where the root of problem lies, windows 10, myself or Roon. im about to do a fresh win10 install and keep my fingers crossed.

I’m quite sure that that Win10N codec pack that is linked to on your KB isn’t available anymore from microsoft to download.

Hi @BoyZonderman,

I just wanted to check in and see if the fresh install of Windows 10 did the trick here for you. If not, you can download the media packs here https://www.microsoft.com/en-us/software-download/mediafeaturepack