Why UTC and not local time?[ticket in]

@support
I recently installed a roon rock. When I created a backup on schedule, I noticed that the time is offset from our local time by 2 hours. Obviously Roon Rock uses UTC time by default. I think it would be great if one could store the local time in Rock or at least make an offset to UTC time.

ROCK’s timezone should not matter, but the UI should compensate so even remotes in different timezones should sync up.

I know we were working on a fix for this. @mike/@ben – what is the status of that fix?

Hmm… I do not want to leave that uncommented. Because: Roon Rock not only has its own UTC time, it naturally also writes this time into the UEFI (bios). If I correct this, it will be reset after the next start. But why is that important? I save the backup daily. And I can only save it if no music is played. So I turn off the NUC in the evening when I do not need it anymore. At 2:55 am I set up a wake-up via bios, because at 3:00 the time-controlled backup is made. At that time, I generally do not listen to music. And here I have exactly the time difference of 2 hours. Because the time in bios is always set to UTC. I do not know any other computer that does that.

Of course, one could argue now that one should not turn off the NUC. But that just contradicts my attitude. I turn off any energy consumer when I do not need it.

Incidentally, it would be great if one could set the option in a checkbox that the rock shuts down after a backup.

It’s done. If you’re scheduling your backups via Roon, you shouldn’t have to think about time zones. You should only see the timezone from the device you’re using as a Remote.

Scheduling ROCK to sleep and wake up is the thing that’s not really supported right now, although feel free to open a feature request for that.

For now, if you’re going to schedule ROCK to wake up using the BIOS on the NUC, you’ll need to figure out your timezone offset.

@mike @danny

I disagree. I’ll show you the problem: The following pictures / screenshots are made at the same time (18:15) and of course with the same roon server. The following images show the timestamps of scheduled and found backups.

From my Windows client scheduled backups

From my Windows client found backups

From my Android tablet scheduled backups

From my Android tablet found backups

From my iPad scheduled backups

From my iPad found backups

These pictures show that for Windows and iOS, the results and timestamps are consistent with what you said. Both are the same and both show the correctly set time. Scheduled at 2:00 am and performed at 2:00 pm. The Android tablet shows the UTC time. And this is offset by 2 hours.

Why do you make it so complicated that the client determines the real time. Here at least we have a problem with Android. Why these pull-ups? The roon core has the time server integrated. It should not be a problem to integrate a correction to the time zone via the web interface. Surely you know Daphile. He does that. Only a suggestion on my part.

Yeah, this is a bug :slight_smile: @ivan, can you take a look at this?

Thanks @StereJo!

I was seek out a answers to the time stamp ”problem” in Rock/NUC and found this thread, and disagree whit @danny, time stamps matters in a network, especially if you trying to solve problems looking through your log. I was trying to find out why I constantly was having problems whit Tidal, and when I went through my logs things didn’t add up because everything that had to do whit rock occurred two hours before everything else in the network log (I am on GMT+2) I didn’t find out about the Rock timestamp issues before I had set the time in my NUC repeatedly, just to find that my sync time in the backup and Tidal sync time stamp went back to GMT+0 after every boot. So I kindly suggest that this is corrected so common practice for network is respected. I can properly be solved by adding a option to the Rock server page.

1 Like

Thanks, @Sony_Doe, @StereJo for your posts, we were able to reproduce this behavior a ticket is in for our developers.


Ivan

Like RoPieee does. A perfect solution.

I just moved over to a ROCK on a NUC8i7 and discovered the time on my logitech transporter is showing UTC - which happens to be 8 hours ahead of me.

There’s another Thread discussing this - and giving no answers.
As a new ROCK user, I have the same issue: Squeezeboxen are showing the wrong time because ROCK is showing UTC.

Also the times given in this info panel are suffering from the UTC versus local time problem and it’s very annoying because they pretend to be relative.

grafik
Core running on a QNAP-NAS with proper time-zone setup; Roon Remote is on Windows.

Alarm Clock for me seems to be using UTC instead of my local time. Any update on this issue?

I guess you talk about this behaviour?
grafik

grafik

Blackjack, I think it is using local time, displaying UTC.

With Roon 1.6 (Build 416) the backup schedule times displayed on android (landscape and portrait UI) are now correct. Also the ‘Extension Authorizations’ screen shows correct relative times on android but is still wrong on windows client (32 and 64-bit).

grafik
Core running on a QNAP-NAS with proper time-zone setup; Roon Remote is on Windows.

Any solution to this? My main issue is that the wrong time displays on my Squeezebox’s and Transporter.