Wi-fi streaming with iQaudio Pi-DAC+ and Roon bridge?


(Mario Capasso) #1

hi, is it possible to use wi-fi connection with raspberry 3 and iQaudio Pi-DAC+ with Roon image flashed? How can I set in this case a password and choose correct wireless connection? thanks a lot!


(Mr Fix It ) #2

You can do this with the diet PI roon bridge installed and activated. While Wi-Fi is not the ideal it does work if your signal is adequate.


(Mario Capasso) #3

thanks. I think I’ll wait for a iqaudio support, I think that a simpler image with less process is better for quality.


(Duncan Rolfe) #4

IIRC; If you plug the SD card back in to your PC, there should be a README file with instructions for setting up Wi-Fi.


(Mr Fix It ) #5

I’ve done this on the DietPi builds and honestly if flashing an image not beyond you anything else on diet pi is not that hard. its free to try other than a little bit of time and you learn along the way. The guys at IQAudio also frequent here too @Gordon_Garrity and I’m sure they can chime in on any build options they can suggest too.


(vova) #6

It is possible - https://iqaudio.co.uk/blog/roon-wifi-what-s-going-on-n8


(Mario Capasso) #7

thanks, I will try…there is a read me txt with this:

This is the IQaudIO RoonReady SD card Image file. There is no user access to the linux file system. Users who want to use wifi connectivity: ======================================== Create a file called wpa_supplicant.conf and place it in the /boot/ directory. An example and details from the Raspberry Pi foundation are included below… Make sure that the parameters are aligned to your own wifi network. If a wpa_supplicant.conf file is placed into the /boot/ directory, this will be moved to the /etc/wpa_supplicant/ directory the next time the system is booted, overwriting the network settings; this allows a Wifi configuration to be preloaded onto a card from a Windows or other machine that can only see the boot partition. Example wpa_supplicant.conf file ================================ country=GB ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 network={ ssid=“YOUR_NETWORK_NAME” psk=“YOUR_NETWORK_PASSWORD” proto=RSN key_mgmt=WPA-PSK pairwise=CCMP auth_alg=OPEN } Wifi network specific parameters ================================ Other parameters are specific to your own wifi network. • proto could be either RSN (WPA2) or WPA (WPA1). • key_mgmt could be either WPA-PSK (most probably) or WPA-EAP(enterprise networks) • pairwise could be either CCMP (WPA2) or TKIP (WPA1) • auth_alg is most probably OPEN, other options are LEAP and SHARED Please ensure that you use those needed to connect to YOUR wifi network. support emails can be sent to info@iqaudio.com


(Mario Capasso) #8

do you think that I need to write: “NETWORKNAME” or just NETWORKNAME without " " ? thanks
p.s. btw does not works with, maybe because it is an external usb wifi (but it’s a good one for rasp pi!)


#9

Within “” quotes is what the WPAsupplicant.conf manual suggests. Could this be a driver issue with the external usb dongle? If there are issues, googling the model # would likely turn them up on various rPI forums. What is the model #?

Alternatively you could use a wifi range extender with ethernet out. TP-LINK has some for like $25. Really simplified my Cubox setup, especially in cases where I want to try a bunch of different images. Ethernet virtually always connects with no user intervention required. One less thing to mess around with.


(Mario Capasso) #10

thanks, wifi extender repeater with ethernet it’s what I’m doing now, but I have a few bugs with roon remote app on iphone, everytime that I open the app roon music stop playing and need to reconnect with PC roon server in another zone of the house where is main router…maybe there is a problem with roon remote and repeater I’m afraid…
anyway this is my wifi pen: https://www.amazon.it/dp/B00N8QKKN0/ref=pe_386201_41597321_TE_item


(Stefan Gliessmann) #11

I have the same problem …
After tailoring wpa_supplicant.conf file to my values, I get no connection.
During boot up I can read on the screen that WiFi is disabled if country is not set (even though I had it configured accordingly).

Any help?
Was anybody able to get WiFi going?

Thanks