Wifi connection issues

Hi all,
I’ve been trying to get Wifi up and running on my RoPieeeXL setup for a couple of days now. I’ve tried with both the internal wifi on a Raspberry Pi 3 B and with a USB wifi dongle on a Raspberry Pi 2. In both cases I’ve no problems with the Ethernet connection, but when I start wifi, reboot and then scan for the SSID, enter the correct password (and I’ve checked this multiple times and made sure the password is correct by cutting and pasting it directly out of my router settings page) the same thing happens on both Pis - After the reboot, the router shows that both the Ethernet and wifi has connected and shows different IP addresses for both. I can still connect to the Ethernet address but when I try to access the wifi IP address it just times out and nothing happens.
When I return to check the wifi settings in the RoPieee web interface via the Ethernet connection, the WiFi Network field in the Network page now shows ‘Error: 0’ rather than the SSID I’d selected on the previous reboot and nothing else shows up in the drop down box. I’m going round in circles here now - I’ve tried setting the Ethernet connection to a static address, I’ve tried pulling the Ethernet cable as soon as I tell the Pi to reboot having set the wifi SSID and password and I’ve tried it with the Ethernet still plugged in. I’ve tried re-flashing a clean copy of RoPieee and updating, not updating and selecting the latest beta version, but I get the same thing every time. I assume I must be doing something wrong as I don’t see anyone reporting major wifi issues - Oh and I’ve also tried 2 different wifi dongles in addition to the internal wifi of the Pi3. Wifi signal is fine, the Pi is only a couple of metres away from the router and I have devices in different rooms showing full signal.
I generated some feedback which is 120af861ba1ef195.
Any help much appreciated. I’ve definitely had this working in the past, but now I’m coming back to RoPieee having added an endpoint in a different room.

I would suggest you forget about the dongles and first get this working with the internal wifi.

So to be clear: it is correct that if you keep the cable connected you get 2 IP addresses.

So please configure the internal wifi, keep the cable inserted, and after the reboot send me feedback so I can have a look.


Looks like I’ve managed to solve the problem. I went back to the RPi 3B. I had the same problem again to start off with so I downloaded a fresh copy of RoPieeeXL and then I loaded Raspberry Pi OS on the Pi before configuring the new installation and made sure the bootloader/firmware was all up to date. Having done this I’m no longer seeing any errors after configuring the wifi SSID and having now removed the Ethernet cable I’m able to access the Web interface and I’ve got Spotify streaming working. Haven’t tested Roon yet but I think all is well here.
Many thanks for the nudge into putting the RPi3 back in place though.

Hello guys,

actually I have the same problem with WIFI connection. I changed few days ago the router and now I’m not able to connect my raspberry pi2 with dongle to home wifi. Ropieee XL works extremelly well and I really like this distribution but I need to use wifi connection. Same hardware work well with other distribution for raspberry and I cannote fiugure out what is going on. Any Idea to check in ropieee software or router setting?

The SSID is found, and authenticated, but strangely no IP is provided to the unit on reboot. Ethernet works fine.

That’s not a guarantee that it works with RoPieee.
You’re probably using a dongle that is not supported.

Have you tried it without the dongle?

Yes but it was working 2 weeks ago!
Same hardware. Same distribution: ropieeexl.
The only Change was a new router: I change my old adsl router to a new FTTH router and I’m not able to connect again. It’s very strange.
That’s the reason why I was asking if there is any setting to check in the router…

Thank for reply

Raspberry pi 2 has not a wifi capability so I need a dongle!

Oh yeah. Duh. Can you send me feedback?