Wifi disconnect after few minutes on RoPieeeXL (RPI 3b+)

Wifi on RoPieeeXL isn’t working. It work only around 1 minute, then disconnects and work only from LAN. Tried update from RoPieee and install RoPieeeXL image - same result. On RoPieee wifi work well. What I did:

  1. Burn image of RoPieee through Etcher
  2. Turn Rpi 3b+ with lan cable and microsd
  3. After install set up wifi
  4. After reboot it working well.
  5. Update to RoPieeeXL, reboot. (tried with wifi and lan connections)
  6. Then if remove lan cable wifi work 1-2 minutes and then lost connection
  7. On network menu there is unknown IP. If try to scan networks looks like only 2.4 ghz display, but also doesn’t work if try to connect.

Logs from different installs:
18b4df51b2985b98
f7dec21ac8ffae09

  1. Turn RPI off.
  2. Turn on, it boot well, wifi working well, streaming Roon.
  3. Wifi disconnect after 2 min, stop working stream and webgui
  4. Connect lan and send feedback:
    b9de60ae423d46fe

A reboot your router might help.

Maybe download one of the freebie WiFi strength meters and see what you can see.

I was of the impression the RPi WiFi wasn’t of the best , could be wrong. Can’t you run it Ethernet, bound to be better

I just experiences similar behavior to what you described but my system only connected to the WiFi for a few seconds. Turns out I had bad SIM card. Etcher flagged that with a checksum error when I tried to burn the SIM again. I loaded a new SIM and everything has been fine since. No idea if this is occurring with your system but might be worth etching the SIM again or trying another SIM.

Main point is that wifi working well without disconnects in same conditions at RoPieee v3.066.
But another test show that it become broken after update to 3.088. RoPieeeXL looks like update to latest version during install so wifi dont work.

P.S. I tried everything, restart router, rpi is close in 1m distance near it, 2.4 ghz and 5 ghz, burn images multiple times, old images of RoPieeeXL, but it updates to latest during install. And it shows that 3.088 don’t work in my case.

Is there any way to install older version of RoPieeeXL ?

2 Likes

my question is how to back v3.066. everythng worked fine them

Ask the man …

@spockfish

It could be related to my issue.
It seems that the dhcp client does not honour the default dhcp lease time and runs some 5 minutes before asking for an update, receieves ACK on the same address and then restart the network subsystem and therefore drops the stream.
It only seems to occur on WiFi .

Just my 5 cents

/t

The 3b+ seems to have problems where your wifi isn’t good. I’ve had the same setup and router in two locations but one was rock steady and the other only has problems. I believe there is interference happening somehow