Wifi issue on one of my RPI3s [Resolved]

Hello. I have a lovely stereo in my den that I am having a devil of a time maintaining connection to Roon.

Setup is Roon core - switch (wired) - Orbi mesh router (wired) - Orbi satellite (wireless) - RPI3 (wireless).

For the last run, I have also tried Orbi satellite (wireless) - ASUS RT-AC68U in media bridge mode (wireless) - RPI3 (wired).

Result is the same either way: the RPi3 appears on the network and in Roon for a moment, then disconnects, then reconnects. Over and over.

Wifi signal is strong in this room after upgrading a few days ago to the Orbi mesh network. However, the same problem existed when using my ASUS RT-AC87U as the router and wireless repeaters or ethernet over power. So, the mesh network doesn’t help.

What is so frustrating is that the RPi3s elsewhere in the home (four others) have zero issues staying connected. And I have five SONOS boxes as well, which stay connected among each other using the SONOS mesh network, including one in the den at issue here. Other wifi devices, such as my Harmony Link and AppleTV, stay connected in the den with no issue.

On rare occasion, the wifi will stay in place for a few songs, and then return to the on/off connection issue.

Getting an Ethernet cable to this room would be costly. Any further suggestions from you all? Thanks. JCR

1 Like

Same thing happening to me, ever since the latest update to Roon Bridge build 81. Just one of my RPI3s is acting up. Frustrating. I just wiped it now and I am rebuilding it. It was on Raspbian and I am switching to DietPi since MOST of my other RPI3s are DietPi.

I have rebuilt this RPi3 three times with DietPi, to the same effect. Is there any reason that using a different Linux build would have a different outcome? JCR

Have you swapped it with one of he other working pi3s you have. That would tell you if it was the pi3 or the location.

1 Like

Brilliant idea that I had not tried – do I actually have a bad RPi3? I swapped two devices and reconfigured for the attached DACs and settings. The replacement in my den was playing DSF64 lossless just fine (!) until I stopped the first album playing and switched albums. Now, it is back to losing the transport constantly. On and off, on and off. So, I think it is indeed the location.

Further suggestions? JCR

Hmm strange. Only other suggestion is an expensive one for another Orbi midway between that location and the next nearest Orbi.

I never found that my Asus router worked that well in extended mode but you could maybe try that midway between the two as test before you shell out on another Orbi.

I tired both asus and linksys extenders with mixed success before taking the plunge with the Orbis. Two work fine for me with no problems. Whereas I did get occasional problems with the linksys and regular problems with the asus.

So here is more to the puzzle. My DAC in my main system, ethernet connected to a renderer controlled through an Ethernet connected sonicTransporter, also stopped playing music. I could see and ping both the sT and the renderer through Fing, and the Sonore uPnP software in the sT reported proper functioning and connection to the renderer. Yet, the DAC disappeared from Roon.

After quite an exasperating period of rebooting the sT, the renderer and RoonServer running on my i7 core, I rebooted the entire i7 server. Lo and behold, the sT connected DAC returned – and so did the wayward DAC in my den.

Short lived, as to the den. Three or four DSF64 songs into listening, and the on/off of the den Roon Player started all over again. Went away for the day – tonight it played 12 songs and then started the on/off syndrome.

However, since it plays fine for a while, it makes me wonder whether there is something more than just the wifi. It’s almost like a buffer filling up over several songs and then collapsing. Roon team, is there anything in the log files that might shed any light on this? Thanks – and happy Easter to all. JCR

@support let’s see is the support gurus can suggest anything.

As you can play sometimes I guess that’s ruling out the likes of a firewall etc…what about dhcp server IP address lease times?

Have you tried with a long wired connection just to prove that’s wifi is the correct suspect?

And now, I must report that I am back to where I started. Roon loses the RPi3 device spontaneously every 30 seconds. Once in a while, I might be able to play through a song. I am thinking that is what had occurrred when I first reported that the mesh network had solved my connection issue. Reality is that was the anomoly. In fact, the title of this thread is off, in that when Roon loses the connection, I can’t ping the RPi3 through Fing.

What I have not tried is turning on the wifi in the RPi3 itself, bypassing the ASUS router configured as a media bridge. Might that be worth trying and if so, do I change to wifi and enter a network key somewhere in dietpi-launcher (assuming I can hold a wireless connection to Putty long enough to do so).

Update: wifi in RPI3 works, but still does the on/off losing transport thing. So that’s not the answer. I’ve ordered a 150 foot length cat6 cable to try a direct run from the main router, just to see if that will work. And I also ordered a second Orbi satellite to try as well. Amazon same day delivery! And I will set this RPi3 to a static address to avoid any potential DHCP lease issues. Will report back on results this evening. JCR

Hi @Jeffrey_Robbins ---- I moved your most recent post from the other thread you had started concerning this issue, in the interest of keeping all of your information in one place :wink:

In your report you mentioned using a switch between the device hosting your Roon core and the Orbi mesh router. Can you please provide me with the make and model of this device?


Eric, thanks for jumping in. The switch is a Netgear GS116Ev2 – 16 port gigabit ProSAFE Plus switch. Its IGMP Snooping Status, validation of IGMPv3 headers and blocking of unknown multicast addresses are all set to disabled. Firmware version is, the latest available. Set in DHCP mode. JCR

An update. I added an additional Orbi mesh wifif satellite into our system, locating it in the hallway about 20 feet outside of my den. Really makes no difference, unfortunately. Having “settled” overnight, the den Roon player successfully played about 10-15 minutes of music, no less upsampled from 24/192 to DSD128, and then the first loss of transport came. Upon restarting the player, it was about two minutes before the next loss of transport. After that, the player started its own on/off disappearing act and any attempt to play is met with an immediately loss of transport and disappearance of the player from Roon.

We can presume there are no firewall or similar issues, or I’d not be able to get the player to work at all – and at least for a bit, it is streaming at rather high resolutions!

There seems to be such a strong wifi signal now in the den, I don’t get it. Putty reports wireless on this device at 72.2 Mbit, -54 dBm. But, I will note that I could not successfully place the Orbi satellite in the den – it could not connect through to the router, hence my locating it just outside of the den.

Now what, crew? Eric@support, is there something mystical to be found in any log files? JCR

Hi @Jeffrey_Robbins ---- Thank you for answering my question and updating the thread with the results of your feedback. I wanted touch base with you because I am curious about the following:

While I understand that the Orbi satellite placed outside the den only yielded positive results temporarily, did hardwiring offer any change here? Furthermore, I see earlier on you had swapped pi3s around as per the suggestion of Philr. From your feedback I see that the newly inserted unit in the den ended up suffering from the same issue, but how did the unit that was originally in the den hold up in another location? Did it perform as expected?


I’ve not tried the direct hard wire run yet. Hopefully, tonight.

Yes, the former Den player moved to our bedroom and is working fine there. It is the former bedroom player that is now my den Player, suffering though it is, although it worked fine in its prior life as our bedroom Player. I still have the Den player connected via DHCP. Should I try a static address for it and is that configurable through DietPi-launcher’s network adapters tool? JCR

Hi @Jeffrey_Robbins ---- Thank you for touching base with me. I would suggest trying with the hardwired connection first, just to see how things behave with the Wifi out of the equation.

Looking forward to your feedback!

Hello, Eric. OK, so I attached a 150 foot length of Cat6 ethernet cable to my main Orbi router in my basement and ran the cable up the stairwell two flights to my den on the second level.

Initially, I thought this was the winner. But, sadly, not so. While the direct connection allowed about 30 minutes of an album to play without cutting out, it ended there. Back to the on/off disappearing act with the Roon player in the den.

So, this is NOT solely about wifi versus cabled connection, to my surprise.

A few other comments to add color. Before I tried the Cat6 cable, I moved the new Orbi satellite into my den. No locale within the den could pick up the backhaul wifi signal to connect the satellite to the Orbi network. I don’t know why this particular room is so difiicult to penatrate with wifi, but the SONOS player, AppleTV, tablets and phones all work with wifi in the den, despite the Roon player’s and the Orbi satellite’s inability to connect properly. But, this is now a sideshow, as a hardwire directly from the router to the player takes the wifi out of the picture.

Now what do I do? I was thinking MoCA for ethernet over cable, since there is a cable TV run into the den. But, the Cat6 run I’ve created should do better, and it’s not cutting it.

Thanks. JCR

1 Like

Jeffery when you put the LAN cable in did you then also disable the wifi and allow the LAN connection to be active?

1 Like

I was wondering about that. I did NOT deactivate the wifi – so both are active. Unfortunately, the device has disappeared completely from the network and so my remoting from my office to my home PC to deactivate the wifi via Putty won’t work. I will take that next step this evening and report back on that. JCR

1 Like

HI @Jeffrey_Robbins ---- Thank you for touching base and sharing the results of this first round of tests using a hardwired connection via the Cat6 cable. Please let me know how you make out with the advice given by @wizardofoz (:thumbsup: :clap:).


@Jeffrey_Robbins I don’t believe that the Ethernet and Wifi can be active at the same time, they are at least if I recall correctly mutually exclusive certainly in DietPi @Dan_Knight but Dan can perhaps confirm this.

You should be able to change it with a keyboard and an HDMI connection to a TV without having any wifi or LAN connection operable.

1 Like