Will not stream using Tital

System Hardware
Innuos Zenith
InnuOS version 1.4.7

Ethernet connected directly to Google mesh system
iPad and Zenith connected to network through the mesh system

**Audio Devices Zenith is connected with Ethernet cable
Output of Zenith USB to Chord Hugo TT DAC
RCA cable output of DAC goes to McIntosh Pre-Amp

Using as a streamer and also ripping CD’s

New setup everything hooked up, subscribed to Roon, Zenith set as core, linked Tidal and Roon together and signed in with both. systems recognizes network and Zenith as Roon core with Huggo TT, when I go to artist and select song every time I hit play I get 10 seconds of play and then get “lost Connection Try To Reconnect”. I have tried rebooting everything and reloading all software but same error. So I ripped two CD’s through Zenith and I it works fine all the way through the CD with no stability issues. This is same Ethernet cable I have been using with BlueSound Node 2 and linked to iPad with no issues. I use a Google mesh system for the house WiFi and connect the Ethernet wire going to the Zenith directly into the first mesh puck to ensure both are on same network.

Found the problem, I replaced the Ethernet cable going to zenith, strange since this was fine running prior streamer but happy now