Win10 can only play in exclusive mode

Description of Issue

Built out a new machine, and after a lot of headache, I’ve determined that Roon will only play when it can get exclusive mode on an audio device. This is fine for my Headphone amp, but not acceptable for my main speakers, where my main use case [on this device] is for background music while doing other things, which will also need access to the speakers.

My previous build was able to play with these devices fine in non-exclusive mode.
Other media players work fine.

Desktop Machine

Windows 10 Pro 21H2 build 19044.2251
i7 12th Gen, 64G Ram

Audio Devices

Headphone Amp
FiiO K5 Pro
Windows Controller Information: “FiiO K5 Pro; Microsoft”

Desktop Speakers
Windows Controller Information: “TC-384Khz Hifi Type-C Audio; Microsoft”

Roon Versions

Desktop: 2.0 / 1148 / 64b
Core [win10]: 2.0 / 1148 / 64b

Is the exclusive mode turned off in the device settings?

Yes, because that’s the desired state.

On my Win11, if I disable exclusive mode for a WASAPI device, I can play both Roon and Audacity at the same time and also hear system sounds.

Right, so when I have exclusive mode disabled in both Roon and Win10 properties, songs I attempt to play just instant skip to the end. This has worked in previous Win10 setups I’ve had. I don’t believe I’ve done anything strange here, and they are all USB devices, so drivers shouldn’t be at issue.

How did you disable exclusive access in Win10? Did you uncheck this?


Roon doesn’t seem to like that. It’s possible Roon needs exclusive access to the device when it sets it up or during startup. Turn that option back on, restart Roon and try again.

1 Like

Okay, that did it… I was able to get Roon and Aimp playing at the same time.

Still feels like a bug that it needs exclusive availability even if it’s not intending to use it

But thanks…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.