Win10 - Listed audio devices cannot be enabled in Roon

I have this same issue. I’ve had the problem for a few weeks now but it’s on a PC which i hadn’t used much for Roon so it wasn’t really annoying me, until now! The connected speakers are Kef LS50 wireless through USB. All the other applications on the PC work fine with the Kefs. It worked great for a couple of months and then stopped. Windows automatic updates are on so I can’t pin down what might have changed. There have been a few Roon updates over the period also.

My setup is:

  • v1.3 (218)
  • Core installed on QNAP TVS-871 i7 16G NAS, on 1TB Samsung SSD
  • library (relatively small at present) also installed on the same Samsung SSD
  • Tidal subscription
  • various endpoints including dietpi/meridian explorer and this PC
  • PC is Windows 10 64 bit pro, i7, 16G, fairly new and not very cluttered as yet

When this first happened, after various reboots I managed to get things working again. Since then the exact problem as described above by Rumiho has been happening - basically the audio devices connected to my PC show in Roon but cannot be enabled. Clicking the enabled button beside the Kef LS50 (eg the WASAPI) results in a Roon “loading” symbol endlessly on screen. Clicking anywhere removes this, but the device is not enabled. Eventually all the devices connected to my PC disappear. Rebooting Roon core and the PC lets them show up again, but still cannot be enabled.

I have tried re-installing audio drivers and also re-installing the Roon core and desktop app but the problem remains.

Other than this Kef ls50 wireless problem, Roon works great with dietpi, sonos and various airplay endpoints. I think it must be something in windows but any thoughts would be appreciated

Hi @James_Keenan ----- I moved your post out to it’s own thread so I can address this issue directly with you :wink:

Moving forward, I would like to grab a set of logs from you and will be contacting you via PM shortly with instructions.