Win10 (Roon core) + Bose Companion 5 no playback

Having the same problem. Works on everything but my Bose USB speakers. Your software did detect my Bose speakers. Running Windows 10. 32 Gigs of RAM. Speakers are a Bose Companion® 5 multimedia speaker system. Bose speakers work for other output audio software such as JRiver, Spotify, etc. Considering of buying the lifetime license if you can solve this problem.

Bose USB speakers are connected to my Workstation where the Roon software resides.

Hey Roon, if JRiver can do this, so should you. Should have been fixed long ago. I am a specifier. No longer able to specify Roon unless this is resolved.

Hi @Earl_Levin — Thank you for the report and sharing your feedback with us. I saw you had posted in two different threads regarding the mentioned BOSE device and have since consolidated your comments into their own thread so we can address this behavior with you directly.

Just to be clear, we absolutely want these to work, and we’ve made changes at least 3 times in the past attempting to resolve these issues, sadly to no avail.

From what we can tell, these speakers (or at least the Bose models we’ve looked at in the past) only accept 6 channel audio, which is a definitively non-standard way to design a product like this. The last time we took a long look at this problem we did not support multichannel, so there may be more we can do now to get this working.

I would like to get your information into the ticket that we are using to track this behavior and as such would very kindly like to ask you for the following:

  • Please provide a brief but accurate description of your current setup using this link as a guide.

  • Just to confirm, the “failure” is that while Roon is able to detect the Companion 5 it cannot play to them, correct?

  • The device setup window for the Bose Companion 5 audio zone in Roon please enable “Work around devices that misreport capabilities” and verify if this action yields a change in behavior.


Roon Version: 1.5 (build 323) stable (64 bit)
Windows 10…most current release.
PC Workstation w 32 gigs of RAM
Music imported using iTunes Lossless. No problem setting up music library and playing on the following devices:
PS Audio Direct Stream DAC via Bridge II: Connection via Network
Sonos at five locations: Connection via Network.

Bose website for PC USB Workstation Speakers, Roon software identifies as directly connected to the PC, where Roon software and music files reside; able to select as an output device with no response:

The Bose system consists of two tweeters and a base speaker. The tweeters plug into the base speaker and the base speaker plugs into the PC with a USB connection.

​All other software, including JRiver, have no issues. Most of my clients have mixed setups from very basic PC speakers and Sonos systems and those that have a high appreciation for audio listening…DAC interfaces such as the PS Audio Direct Stream with a Bridge II Network Link. I usually sit the Owner down and show them available software and how it works, along with other systems such as Lutron Homeworks QS. I want to include Roon as part of the selection process, however, I am unable to do so until this is resolved.​

Appreciate your help in getting this resolved.

[Personal information removed by support]

Hi @Earl_Levin ----- Thank you for the follow up! A few things continuing forward…

  1. Were you ever able to test with mentioned setting enabled in Roon? Curious as to what the outcome of that test was.

    “The device setup window for the Bose Companion 5 audio zone in Roon please enable “Work around devices that misreport capabilities” and verify if this action yields a change in behavior.”

  2. I would like to enable diagnostics on your account so our techs can have a closer look into this behavior. However, before I enable this feature please reproduce the issue and note…

    • The time of day when the issue occurred.
    • What track and/or album you attempted to play at the time of the error.


Did that for multiple albums and selected playback. Does not work. Speaker options for selected speakers (Bose) is grayed out and says “nothing playing.” Just tried it again: Album: Joey Monk Live, Track 7. 9:33 AM 7/3/18. Hit “play now”, track 7 for Bose Speakers. It says “playing now.” Speaker options for selected speakers (Bose) is grayed out and says “nothing playing.”

Hi @Earl_Levin ---- Thank you for confirming that information for me and providing the requested timestamps!

Now that I have a sense as to when the error occurred I have gone ahead and enabled the mentioned diagnostics on your account. What this action will do is the next time Roon is active on your core machine a diagnostics report containing a set of your Roon logs will automatically be generated/uploaded directly to our servers. Once the report has been received I will be sure to reach out again so you know that we have it.


Hi @Earl_Levin ----- Thank you for your patience here and my apologies for the wait.

I wanted to touch base with you to confirm that the mentioned diagnostics report has been received and is currently with our tech team for analysis. Once the team has updated your ticket and passed it back to me I will be sure to share their thoughts/findings with you in a timely manor. Your patience during this process is appreciated!


Hi @Earl_Levin ---- Thank you for you patience here while out techs have been reviewing the diagnostics report we had received from your system. Very appreciated!

The team has completed their analysis and updated your ticket, which has been passed back to me. As per the update the team would like you to confirm if the following adjustments yield a change in behavior with the Companion 5 speakers. Kindly see below.

In the “device setup” window for the Bose audio zone…

  1. Please set the “channel layout” to “5.1”
  2. Make sure “Send stereo/mono content as 7.1” is in the “off” position.


Bose USB 5.1 Workstation Speakers now working. Thank you for fixing this.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.