Windows 10 machines do not see Nucleus on the network

Roon Core Machine


Networking Gear & Setup Details

tp-link AX5400 (Archer AX75) connected via ethernet cable through one switch to Nucleus.

Connected Audio Devices

Teac UD-505 via USB

Number of Tracks in Library


Description of Issue

The router lists Nucleus as a LAN client. My old Samsung Galaxy Tab 2 can connect to the Nucleus and works normally although my Samsung Galaxy S21+ phone cannot find the Roon core even with the up-dated app. None of my three networked Win 10 PCs can see the Nucleus on my network. This is a brand-new Nucleus from Roon Labs. It is replacing an Roon-authorized home-built NUC-based server which became inoperable due to a power switch failure 2 months after the warranty expired. It was seen on the network as ROCK but also had intermittent network visibility. Any suggestions?

Are you running Roon 2.0 on all of your client Remotes (Samsung devices and W10 PCs)? Can you confirm that on your W10 PCs you have firewall exceptions for roon.exe and RAATServer.exe?

Thanks, Robert, for your quick response. I can run Roon on all of my PCs just as I can on the Tab 2. But I don’t want to use the PCs as remotes. What I want to do is to cut, paste or edit files on the hard drive connected to the Nucleus, from any of my PCs. This is what I was able to do with the old NUC server. In that case, ROCK showed up as a network drive in File Explorer. Is it not possible to do that any longer?

Hi @dick_schoener,

Can you try this and let me know what happens?

Windows Key + R
In the command line, type \\ and see what comes up. If asked to provide user credentials, just use the username guest and no password.

If this works for you, you’ll need to map the drive in Windows Explorer. Please keep in mind the painfully long timeouts in accessing this share if your router decides to give your Nucleus a new IP. Setting your Nucleus to a static IP will prevent this for you though :slight_smile:


Hi Wes,
I tried your suggestion, but Windows could not find that location. Thanks for offering some help.

I was missing a slash! My apologies.


If that doesn’t work try \\data


Hi Wes,
I think you had both slashes, but I might not have typed them. Unfortunately, I will not be able to try
any more suggestions until I return from an OOT trip on Nov 4. Sorry for the interruption, but I will resond to any posts in the interim.

For some reason, the forum is not letting my formatting go through. There should be two slashes in front of the IP address.

Let me know how things are going when you get back. I’ll be ready to help.


There you go: \\\ or \\\data

the backslash is an escape character. For 2 backslashes, you need to actually have 3 in your post :slight_smile:

1 Like

Didn’t know that! Thanks, @Nepherte!


Alternatively, you can just use two slashes but select the string and use the preformatted text icon in the editor (</>), thus:


1 Like

I’m back and tried entering the location with the appropriate slashes and then adding/data but to no avail. Also, I use the phone app Fing to find IP addresses on my network and it found everything except the Nucleus. So, I’m open to any other suggestions you might have.

Hi @dick_schoener,

This is all so very odd. When we first spoke, I was seeing your Nucleus online and reporting to our authentication servers. Today, that was still the case but the connection for it wasn’t consistent. After trying several times unsuccessfully, I have finally enabled a flag on your account to try and remedy this and the unit seems to be reporting back with 100% consistency.

Can you try things again and let me know how it’s going?


After my last reply, I began to suspect malfeasance by Windows Update which always occurs when Win has an update lurking in the background. This situation always interferes with my 3 networked PCs being able to communicate with each other as well as some individual programs not functioning normally. So, after updating all three, I was finally able to access the Nucleus on all three using your method. Then, by adding it to Quick Access I don’t have to type it in after each reboot. Now, if only I could change the name from to Nucleus, things would be back to normal. So, for now, your help has gotten me to a working fix, that is, until Win Update strikes again. But now I will know what the problem is and how to fix it. Thanks again for your interest and support.

1 Like

Hi @dick_schoener,

When we arrive at a resolution it’s always good news. Please let us know if you experience any further connectivity issues.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.