Windows 10 not updating Roon app - out of sync with Roon core build

Roon Core Machine - Innuos Zen Mk3 Build 831

DELL Latitude 5410
|Processor|Intel(R) Core™ i5-10310U CPU @ 1.70GHz 2.21 GHz|
|Installed RAM|8.00 GB (7.61 GB usable)|
|Product ID|00329-00000-00003-AA250|
|System type|64-bit operating system, x64-based processor

PC build is on 806 and not updating. I cannot seem to force an update. Now out of sync with Core. Roon works fine but no “versions” tab on each album and can’t choose which version (Qobuz/Tidal) to add to library in the Roon app. Tried to uninstall from PC but uninstaller not working and no other method works.

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

Go to the roonlabs site and download the app from there.

Try deleting Roon on the pc and reinstall fresh.
That should bring it up to date

Thanks guys - yes tried that. The uninstaller comes up with an “error” and won’t uninstall the app. Tried to overwrite it with a download and that failed. Tried a few different ways to uninstall the app on Windows 10 and no joy.

So I managed to delete Roon by going into the HKEY root menu and doing it manually. Quite the process as the app is somewhat “hidden” in Windows. Now I can’t reinstall the app from the Roon download! Keeps coming up with an error in 32 or 64 bit mode.Annotation 2021-10-04 161328
Ignoring just installs an unusable app, retry comes up with the same error and abort is obvious!

Try running the install program as administrator.
Then try suspending anti virus.

Hey @Neil_Whisson,

I am so sorry we didn’t get a chance to reply until today, especially in an issue as pressing as this one :pensive: .

I was wondering if, after having discussed this at length (thank you and thanks to @ged_hickman1 and @AceRimmer for the suggestions), things improved at all? Even if this late, if there’s anything we can do, we’d love to help :nerd_face:

Hi Rebaka,
I think in the end it has something to do with the firewall on my PC (work issue) for which I don’t have a workaround.
Just FYI, I’m using my iPad Pro 12.9 and it too wouldn’t automatically go up to build 831. I had to delete the previous version and install a new version.
Seems to work fine.