Windows 10 Roon as remote hangs [Solved - Intel Display Driver Issue]


Can’t figure out why my Roon software running on a Windows 10 PC (i3, 4GB RAM, 5Ghz wireless) hangs once i’ve typed in search criteria or hangs when displaying album art or any other function is not immediately selectable. I use iPads as well with no delay/issue. This didn’t happen with v1.4, started with v1.5 Roon core is Windows 10 Pro, running on an i5 NUC, SSD, 8GB RAM and gigabit ethernet. I’ve updated drivers, optimized wireless config - changed channels, etc. no difference. I’m using a Bluesound wireless speaker and a bryston BDP3 via ethernet, no difference in performance.

Hello @Ian_Drachman,

Thanks for contacting support, I’d be happy to take a look over your issue here. Just to confirm, the Roon Core is the Intel i5 NUC with an SSD and you are using the i3 Windows 10 PC as a Roon Remote, correct? Can you please try to temporarily connect the i3 Windows 10 PC via Ethernet directly to your Router to see if you are experiencing the same delay? If connecting it to Ethernet solves the issue then this would likely be network related. Can you also please try and see if clearing the image cache provides any performance increase? I have attached a screenshot of where to find the Image Clear option here:

One last option would be re-installing the Roon Remote or Roon Bridge you have on your i3 Windows 10 PC to see if that solves the issue. Please let me know after you have tried these steps, and if the library is still loading slowly I can provide advice for other possible solutions.


@Ian_Drachman I assume you have updated all the roon instances to the latest version (V1.5 B323)

Hi cleared cache. No change and to clarify it’s not just the library loading Slowly only. The mouse doesn’t change and I can’t select any feature including play/stop, etc.
I will try Ethernet on Friday.
I removed and reinstalled via download the latest roon software. Yes I’m on latest build. I tried tidal and it’s cover art takes a while to load and I can’t select another item until the control returns. This leads me to believe its network related too. More feedback once I’ve tried Ethernet.

Exactly what i3 cpu are you using? Does it meet the minimum specs of ivy bridge i3-3xxx? Tho even at min spec you might not have the best performance experience.

Also what graphics driver is it using…if it’s intel HD then there are some things to try like using a 32bit install of Roon Remote that is a workaround.

I3 2.9ghz. 3240t processor. Windows 10 64bit 4gb ram. I’ll try 32bit. It worked! Quite a difference in Performance. I did perf monitor with 64bit and didn’t see any consistent t spikes in memory, cpu or network. Didn’t think 32bit would be different, though slower. Not at all.
I’ll keep 32bit for now. Thanks!

It’s a driver issue. Some versions of the 64bit Intel HD Graphics driver cause redrawing problems with the OpenGL graphics library used by Roon.

Yep another Intel HD driver issue…how many times have we seen this…

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.