Windows 11 Surprise - "There was an issue loading your database"

Roon Core Machine

Windows 11
Homebuilt Windows PC i7 9770 16gb RAM

Networking Gear & Setup Details


Connected Audio Devices

iFi iLink

Number of Tracks in Library

Big, I don’t take note before it stopped working.

Description of Issue

I upgraded my main HTPC to Windows 11 after it went so well on my gaming PC. All went well again and I was delighted that Roon appeared to work fine. I ran it for a few hours, listening to music and shut it down happy it all worked but on turning it on the next day an update request showed, the update finished followed by the necessary database update which resulted in the following error Untitled - lanceness's

So I restored the database from a backup which took a bit, it showed as successful but when the program went to add new content since the backup I got the exact same database error. So I went to the help center and did as instructed. I deleted the program and all data since the database restore did not work, I logged in and it started to find music and appeared to work but about a half hour later I got the same database problem message.

What do I do now? Is there a way to roll back the version for testing? I know it worked just fine on Windows 10 and appeared ok on 11 before this last update which is now version 1.8 build 884

I worked off of a backup of my windows 10 install but having exchanged my windows 10 license for 11 on this system even a restore of 10 no longer works once it gets a sniff of the internet, that is between me and Microsoft, if I can get Roon working I will keep Windows 11 which works better than expected aside from this.

Please advise.


I tried something just now, I uninstalled Roon again and reinstalled the latest version then overwrote with a copy of the Roon directory from my backup which allowed me to once again run on the previous version build 831 and it worked fine again just like it did before. I even deleted the storage location of 4 separate music directories then re added them to get it to reread them which always causes the error under 11 after the update and that went fine. I will let Roon update then test again but I would bet that it stops working after the update to build 884.

Is there a way to hold the update until this is worked out or do I just leave my system on until it is or go back to windows 10?

Well, I don’t think Roon has stated that Windows 11 is officially supported yet.

Aha, then how do I keep the build from updating because build 831 works fine but 884 corrupts the database.

Build 884 should fix all of the false positive issues we were having related to database errors so you’re either encountering a rare case that we didn’t catch or something is taking place that is corrupting your database.

Do you have a copy of the Roon install / db directory saved that reflects the state after you got the corruption errors? If not it would be extremely helpful to us if you could get your machine back into that state and then quit out of Roon and save a copy of your %localappdata%\Roon folder before re-installing and restoring. This will allow us to see what is going on in your specific case and will ultimately lead to a faster resolution.

If you’re willing to go through this one more time please ping @support when you have a copy of your Roon folder and a team member will make arrangements to get a zip of your logs. Please don’t throw out the ‘corrupt’ Database as we may want to take a peek at that as well.

As for holding back updates, you can request to be asked before downloading updates on the Settings → About screen:

1 Like

Yep! I had the option selected to ask when to download the update files the whole time but it repeatedly updated anyway and failed again so I was done, I went back to windows 10, “let” it update and it made it through the database update and is working fine now. I would have been happy to send you the logs if I had heard from you first. So currently running build 884 on 10 where it works fine.

To do it now I would have to reinstall 11 and run Roon, from there it would be pretty easy to get it to fail since it is already running 884 if this would help you make it compatible with 11 I would do that.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.