Windows 7: Roon stopped outputting bit-perfect audio (i.e. Lossless) via optical connection

For some reason, Roon just stopped outputting lossless audio. Even when I select my DAC (a Maverick Audio TubeMagic DAC1 Plus, which is connected via an optical cable), the audio stream is downsampled to 48kHz, truncated to 16bits, dithered @ 16bits, and then output direct via WASAPI exclusive mode.

I haven’t made any changes to my setup, other than adding a few CDs to my collection that I ripped this afternoon.

I’m using Windows 7 64-bit


I just tested with both the USB input to my MavAudio DAC as well as the USB input to the Meridian Explorer DAC that I have, in in both cases Roon IS outputting in lossless. It seems that for whatever reason, lossless via optical has stopped working all of a sudden.

Hey @yorktronic – I assume you’ve already confirmed everything is as expected in audio setup? This probably means you want to confirm exclusive mode is on, and sample rate limiting is off.

Let us know, and we can gather some info and take a deeper look if needed.


Exclusive mode is on, though I don’t see a sample rate limiting setting in Roon. That said, I have tested via the Windows “Supported Formats” section of the audio settings for my MavAudio, and it outputs the test tone sound at all high res settings. In Roon, anything over 16/44.1 is downsampled on both the digital coaxial output as well as the optical output.

It seems strange that the type of physical connection to the sound card would make a difference in Roon, and I’ve definitely listened to lossless via the optical cable before, without it being downsampled. So strange…

Edit: when I force Windows to output at 24/192 in sound settings and play audio with Foobar 2000, it plays and indicates in Foobar that it’s 24/192 (though idk if Foobar is just saying that based on the file or actual sound output). I don’t have an oscilloscope to test it.

Okay so it’s not a hardware issue with my DAC - I connected my Macbook Pro via an optical cable and Roon on OSX outputs at 24/192.

Ok @yorktronic – I’m going to follow up via PM so we can have a look at what’s going on here.