Windows ASIO driver output via ROON not working [Resolved]

Hello, I am using a windows 10 computer with source of hard drives connected to a DAC and then to my amplifyer.

I am trying to figure out a way to force ROON to use my asio driver and pass the signal directly to soundcard -> SPIF.
This instead of touching the ROON volume mixer, after that passing it on to the Windows volume mixer and then to the souncard.

I have enables ASIO in the ROON settings but I can still use the volume control in ROON so probably I am doing something wrong here…

With other programs (as foobar or albumplayer) its is so easy but wit ROON i cannot identify the way of working yet…

Can anybody share his knowledge of settings with me?
Thanks so munch,

I’m not 100% sure, but I think you are wanting to disable Roon volume control, does this help?

Roon - Settings --> Audio --> [ASIO] Zone --> Setting --> Device Setup --> Volume Control Mode --> Fixed

Thanks for the help…found it to work now…

Only strange thing is that when selected as ASIO now ROON converts my HQ 24bit files into 16bit files before passing it on to my soundcard. When selected output Roon- volume mixer window- soundard it does not do such thing.

ASIO is designed to be used to pass the clean and raw data on to the next device (DAC) so i do not get it why ROON is is down converting a HQ file

Can you post a screen shot of Roon’s Signal Path?

Also check in Roon DSP Engine --> Sample Rate Conversion to see if a max sample rate has been inadvertently set.

OK let me try to figure out hoe to incorporate me immages here…

Sorry :frowning:

Just drag them into the text entry box. :slight_smile:

Really? - I’ve been clicking the upload icon and browsing all this time, when a simpler method was right under my nose. I learn something new every day…


Hi Carl, Rest of the settings are not enabled like DSP and so on, volume control also off…

Hi @Dave_Schoonenberg ---- Thank you for the report and the continued feedback, both are appreciated. My apologies for the slow response.

Moving forward, to help me better understand what could be causing this behavior to occur may I very kindly ask you to please provide me with the following:

  1. Please verify the make and model of the DAC you are using.

  2. Can you please provide screen shots of the “device settings” you are using in Roon with the DAC. This information can be found by clicking the “gear” next to the desired zone in your “audio” tab and selecting “device setup”. I need complete screenshots of all three tabs in the pop-up window: “General”, “Playback”, and “Zone Grouping”.

FYI: How to take a screenshot on Windows


Hi Dave, ASIO can have a configuration program. For my sound card, ASIO defaults to 16 bit and I have to go into it’s configuration software and set it to 24 bits. See this other thread, it might help.

Hello Daniel and Rugby,

Yes its indeed something in my ASIO driver… I read in your thread to check if with WASAPI its fione… and indeed then the 24 bit stays okay.

So I am going to take some time to figure out what shapenning in my ASIO drivers…

Thanks both,

Yeahhhh, it works guys… I double checked the ASIO drivers and finally made it… now everything is okay…

thanks for everybodys help!