Windows Defender Antivirus Cannot Enable Audio Devices

Ok, I tried to uninstall, there is no difference. I should note as well that every time the computer reboots it re-installs the Realtek drivers again. Weird, but since Roon used to work properly before the firewall was switched I’m not sure the driver is the culprit.

Also, I was wondering if HQPlayer might be a possible work-around. It wouldn’t be a cheap workaround though…

Hi @J_B ,

As the next test, I suggest trying to wipe out the RAATServer install and start fresh, please use these instructions:

You can generate a new RAATServer instance on your device by following these instructions, but please be aware that this will reset your Roon Settings → Audio Tab to factory settings and I would advise making a backup of any custom DSP settings you have:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Ok, I tried it on both the laptop and the core and there was no difference. In fact I didn’t even lose the Audio Tab settings. It did create a new folder though (on the laptop not the core). But again, no difference otherwise.

Hi @J_B ,

Thanks for trying the Realtek ASIO driver uninstall. I looked over your case again and I noticed you mentioned this:

Roon requires more ports than just those to function properly and sometimes even uses randomly-generated ports, have you asked IT to see if they can add application-level exceptions in place, even temporarily?

They said they cannot do it on a permanent basis. I can ask for temporary to see what they say…

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.